What's going on?: After selecting Silverlight Navigation with Accent Color from Online Templates in Microsoft Visual Studio C# 2010 Express, I am receiving the following error message.

Error: this template attempted to load component assembly 'Microsoft.VisualStudio.Silverlight, Version=, ...'. For more information on this problem and how to enable this template, please see documentation on Customizing Project Templates.

What have I done?: I've gone to the page that allows you to customize project templates, but I still don't understand what needs to be done. To be more specific, I don't understand if this requires some coding process behind setting up a custom template (if so, I have viewed it and it doesn't make sense).

Question: Is there a simple "click here and select this check box" (Ex. Click on Tools, click on Templates...) that isn't mentioned in the documentation? If not, what more can I do?


These threads contain some suggestions for what can be done :

Creating new MVC 3 project Error: this template attempted to load component assembly
Error creating a new project of a Custom Feature Extension

Evidently there can be more than one reason for such problems, and I don't have your environment.

In extremity, you might try to repair or reinstall all the software involved in a logical order, starting with Visual Studio and going on to extensions.

  • I repaired, uninstalled and reinstalled the program... no luck. I also tried disabling and enabling the extensions... still no luck. I will try to create a blank Silverlight document at school and open it up on my laptop tomorrow. – Rob Apr 25 '12 at 1:21
  • The computers at my school don't have Silverlight and I can't modify any programs (I don't have administrative access). – Rob Apr 27 '12 at 0:26
  • Have you installed a beta version of Silverlight or VS2010 ? Have you fully patched Windows Update including optional items? – harrymc Apr 27 '12 at 5:37
  • Windows Update is fully patched, includes optional items, and I just installed Silverlight 5. On the other hand, the version of Visual Studio I am using is for "evaluation purpose" only (I have about two weeks left). – Rob Apr 27 '12 at 11:22
  • My question was because beta versions are hard to install over. You could verify your setup against this answer for prerequisite software for Silverlight development (taking instead the 2010 versions), in case your problem is of some missed-out assemblies, so the Silverlight assembly can't load. Event Viewer might also contain some more info about the error. – harrymc Apr 27 '12 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.