17

How do I turn off the little popup bubble in systray that says "could not reconnect to all network drives"?

I am aware that a particular drive is only accessible at certain times so I don't need an annoying little popup message every time I reboot.

I've seen similar popup messages get hidden through means of the registry editor, but Google turned up no answers for this one.

12

My googlefu returned this

Probably you have noticed that Windows 7 will pop up annoying messages when not being able to reconnect network drives on boot. If for some reason they have to be unavailable you can disable pop up message using following registry change:

Hive: HKEY _CURRENT_USER

Key: Network

Value Name: RestoreDiskChecked

DWORD Value: 0 = disabled, 1 = enabled

you may have to create the RestoreDiskChecked Dword if it is not present.

| improve this answer | |
  • This won't work for Win7 Pro SP1 PL. I'm looking for the reason... – kbec Jan 25 '13 at 18:59
  • Doesn't work in Windows 7 Enterprise either. I can repeat this everytime with my account. We map the O: drive via the AD user object. Persistent mapping is on so there is also an entry in HKCU\Network. What happens is that I think Windows attempts to reconnect the persistent mapping after the logon process has already mapped it, thus generating the error – munrobasher Jul 30 '14 at 14:34
  • 1
    This doesn't seem to work in Windows 10 Home (64 bit) either – binaryfunt Sep 17 '15 at 11:29
  • However, in combination with Victor's answer, it appears to have worked – binaryfunt Sep 18 '15 at 9:25
12

Pasted from here:

I know this might be an old thread, but in answer to the OP's question: "Is there anything I can do to to prevent that message from popping up along with preventing the icon from displaying in the system tray?" Yes, here is one thing you can try:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\

Set or create a DWORD

RestoreConnection = 0

This works, at least in W8.1 !

| improve this answer | |
  • 1
    This worked for me on windows 10. – Briefkasten Sep 10 '16 at 14:02
  • This, on its own, works in Windows 7 Ultimate SP1. I recommend this be marked as the answer, since OP asked about Win 7. – psychometriko Nov 6 '16 at 14:57
12

This solution worked for me on Windows 10. It uses both Moab and Victor's methods.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\

Create a DWORD value, name: RestoreConnection, value data: 0

HKEY _CURRENT_USER\Network

Create a DWORD value, name: RestoreDiskChecked, value data: 0

| improve this answer | |
  • Can confirm this worked for me on Windows 10. Had to have both for it to kick in! – Jeff Nov 7 '18 at 0:33
  • Did not work for me. Windows 10 Pro x64 – Joseph Kreifels II May 15 '19 at 13:27
0

See if this will work better and far easier?

Using gpedit.msc

Typed it on the search box in the menu bar,

  1. Selected “Windows Settings”, then
  2. Selected “Security Settings”, then
  3. Selected “Local Policies”, then
  4. Highlighted “Security Options”, from there on the right pane
  5. Select “Network security: “LAN Manager authentication level and set the drop down menu to “Send LM & NTLM –use NTLMv2 session security if negotiated”.

Then just reboot the system.

| improve this answer | |
0

I had the same problem.I have an Epson Printer xp-610 with a card reader open network centre and delete the icons that are showing not connected.yhey are the drives for the card reader .Job done then if you want you can reistall the same. Hope this is of some use.

| improve this answer | |
0

In addition to those things, which did not seem to help, I did the following, for each of the network drives:

  • Set "available offline"
  • Stop that process as soon as one can
  • Set "not available offline"

For some reason this seemed to do the trick.

| improve this answer | |
0

WIN 10 -

when the message pops up -> open the notification center -> Rt click the “could not reconnect to all network drives” message (be quick about it before the message disappears) -> Lt click the disable notification

That solved it for me :-)

| improve this answer | |
-2

This solution worked for me on 4 computers:

Start > Run > type "gpedit.msc" (without quotes) click ok. Local Computer Policy > Computer Configuration > Administrative Templates > System > Logon > Always wait for the network at computer startup and logon set this to Enable

Start > Run > type "gpedit.msc" (without quotes) click ok. User Configuration\Administrative Templates\System\Scripts\Run logon scripts synchronously set this to Enable

Then reboot.

| improve this answer | |
  • This doesn't disable the message like the question asked for. It makes the computer boot slower waiting for the network to become available. – scott.squires Nov 9 '13 at 3:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.