I have files and folders in a TrueCrypt volume that contain the character :, which is not tolerated by Windows. These files were named with this character on a Linux system. When I opened the TrueCrypt volume with Windows, at first the files where shown but not readable, but now, they don't appear at all. However, they should still be there, because they still take space on the volume.

I tried recovering data with Stellar Phoenix but it did not show anything. I also tried mounting the truecrypt volume on a Linux system, but the files don't show up anymore.

Is there any way I could manage to recover those files?



Now what basically Windows does when you give him an forbidden name file, he creates an error report, deletes the filename and changes it to the last working state. Since he couldn't find that last working name, in my opinion he deleted the file. Since it is a TC Drive, the files may not be recoverable because of the security measures of TrueCrypt software. Just in case try accessing them using command prompt in both OSs. And use more than one recovery software, like Recuva (Free), EASEUS Data Recovery Wizard (Free Trial but will do).

  • Well, I tried browsing the files on a Linux, and I also tried Windows command line and some recovery softwares, but nothing worked for me :-( Too bad. Thanks anyway! – piwi Jun 4 '12 at 5:42
  • Unfortunately, you were correct! Since it was a TrueCrypt drive, the files could not be recovered... – piwi Jun 14 '13 at 10:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.