0

I have created an application I send (by email) with ClickOnce with Visual Studio C#. Someone gets the following error:

Your administrator has blocked this application because it potentially poses a security risk to your computer. Your security settings do not allow this application to be installed on your computer.

He uses Windows 7, 64 bits.

What can/should he do to be able to install the application?

Thanks in advance.

  • Do you have any install rights at all? – soandos Apr 22 '12 at 20:30
  • It's not my computer ... you mean he might not even have administrator rights? I would have thought another warning would be given (that it would not be because of security risks) – Michel Keijzers Apr 22 '12 at 20:32
  • 3
    Did they launch it from the email client, if launched from the email client, copy the file to a folder on the hard drive, then try launching. – Moab Apr 22 '12 at 20:45
  • That sounds like AppLocker or Software Restriction Policies to me. If so, the computer is probably configured so that it won't run any software that hasn't been explicitly approved by the system administrator. He should probably ask his tech support people for assistance. – Harry Johnston Apr 23 '12 at 4:44
  • Thanks .. still awaiting his answer if he has administrator rights (I assume it's his own computer at home; not work related). – Michel Keijzers Apr 23 '12 at 8:13
1

I think the issue really is that the system has the flag "do not allow unsigned code" enabled. This would make the downloaded file "blocked" by default if the code is not signed. Did you sign your code with a valid Authenticode certificate? Ask the user to right click the executable, and then find the "unblock" button. I cannot remember exactly which tab the button is on. I think that might fix your issue

  • Thanks for the answer; I'm afraid I cannot contact the person with that specific problem. I don't have the problem myself. However, my code is not authenticated (I would need a costly MS verisign code which I cannot afford as it is being used for a hobby project). – Michel Keijzers Aug 20 '13 at 20:17
1

Make sure the following registry keys are enabled:

[HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\.NETFramework\Security\TrustManager\PromptingLevel]

LocalIntranet = Enabled

TrustedSites = Enabled

The Logitech mouse/keyboard driver update appears to be disabling these registry keys.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.