4

I have Outlook's default language set to one language, but when I reply to an email written in another, my proofing switches to that language.

In my case, the languages are English (US) and English (British). I'm using Outlook 2007, and all my windows region/locale settings are set appropriately.

  • 2
    You will need to go into your spelling and Checking options in Outlook options. -> 1.) options -> 2.) Spelling section -> 3.)spelling and auto co..-> 4.) Change or remove languages. Unfortunately Without having access to 2007 as I currently use 2010 I can not give you a definitive answer. Hope this helps. – onxx May 2 '12 at 15:36
7

It's because the automatic language detection feature is turned on. To switch it off:

  1. Open a new e-mail message.
  2. On the Message tab, in the Proofing group, click the arrow under Spelling.
  3. Click Set Language Button image.
  4. Un-check the Detect language automatically check box.
  • 1
    In Outlook 2016: Review group > Language > Set proofing language – Marco Lackovic Mar 29 '16 at 7:29
4

Inspired by Onxx's comment, I found the solution;

  • Tools, Options
  • Spelling and AutoCorrection
  • Popular (?!)
  • Language Settings
  • Editing Languages -> Set "Primary editing language"
  • Editing Languages -> Remove undesired language from "Enabled editing languages"
  • 2
    The Outlook 2016 location is File|Options|Language Choose Editing Languages section. – Pekka Feb 20 '16 at 12:37
3

I'm using Outlook version 14 packaged with Microsoft Office Professional Plus 2010.

In order to force the proofing language to be my dialect of English, I choose "File > Options > Language", then (if it's not already present, "[Add additional editing languages]" and) specify my language as the default in the "Choose Editing Languages" pane, and remove the other languages. Outlook requires a restart after this change.

3

On my own side with Outlook 2010 (where I'm more intersetd in Autocorrect than proofing), the following worked:

While inside a message:

  • Review -> language -> language (2nd time) -> proofing -> set proofing language,
  • while that dialog is still open: "Set as default language" = yes, "Detect language automatically" = no.
2

For Outlook 2013:

1

After app restart works on new messages.

0

The solution I found to this problem is to add English as a new language to windows along with your own keyboard selected (to not have wrong characters while writing)

When using Office programs, the proofreader always switch to the language selected in the language bar. If no language bar is present, you have only one language selected on windows and office programs' proofreader switches to this language.

0

Go to settings > Region & Language.

In "Keyboard and Languages" > click Change Keyboard.

Click "Add" Button

click the "+ button for the language that you want to spell check in".

Then Click "+ keyboard"

Now "+ Show More" option tick button

Select the keyboard you have.

Now click "ok" and you are done.

You can then also move you alternate keyboard language up into default position by clicking on it and clicking "Move Up".

so you could have English language with Spanish keyboard or vice versa.

Hope this helps FYI I was in win 7 Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.