I just received a new unformatted 2.5" hard disk (1 TB) and an external USB 3.0 enclosure to use with my laptop (Thinkpad). I'm running Kubuntu 12.04 on my laptop.

How do I access and format this HDD when it is connected via USB? I have installed it into the external enclosure and connected it to my laptop and it is powered on, yet it does not show up with either sudo fdisk -l or blkid. The only device that shows up is /dev/sda.

The USB HDD also fails to show up in the GUI Partition Manager too, unsurprisingly.

When I plug the USB HDD in, I get message like this:

attached enclosure device
attached scsi generic sg2 type 13
uas_eh_abort_handler tag 0
uas_eh_device_reset_handler tag 0
reset high speed USB device number 5
Device offlined - not ready after error recovery
rejecting I/O to offline device

I ran into a similar problem before on a desktop and the only solution I found was to connect the HDD to an internal sata port and format the disk. Then I could use it while connected via USB. Currently I am traveling and I only have access to my laptop.

Assuming I cannot connect the disk internally on my computer and I don't have access to any other computer to do the same, how can I accomplish this task? I need to initially partition and format the disk (ext4) via USB.

Update: the drive+enclosure are recognized in Windows. Windows allowed me to partition and format the drive.

  • show output of cat /proc/partitions to see if kernel sees the disk – jet Apr 24 '12 at 19:17
  • I gave up. There is some incompatibility between Linux, the drive enclosure, my laptop and USB 3.0. The drive+enclosure could be recognized and formatted in Windows, but nothing I tried would work in Linux. I ended up using a USB 2.0 enclosure and I got it to work in Linux. It sucks that Linux still has so many problems with USB 3.0. – MountainX Apr 25 '12 at 2:01

I ended up using a different USB enclosure and I got it to work in Linux.

I know this isn't a product review site, but in this situation my problem was hardware incompatibility and I had to waste money buying two products to get one that worked. So I'll share the details to save others the problem.

The Rocketfish Rf-hd3025 USB 3.0 2.5" Sata Hard Drive Enclosure, which is a very nice looking product, appears to be incompatible with Linux (at least it does not work with Ubuntu 12.04 and a Thinkpad laptop). It costs about US$20 and it looks great, but I could not get it to work in Linux. (It worked with Windows.) It also uses a properietary split USB cable that takes up more bulk, which can be important if you are lacking space in your travel bag.

The USB 3.0 2.5 Inch SATA III Drive Enclosure Case does not exhibit the same impressive looking design, but it is smaller (which I like) and appears solidly made. Most importantly, it works with Linux. It is fully powered by USB which is very handy. It also uses a standard USB cable. It also costs about US$20. YMMV.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.