I have a WRT160N V3. I'm getting 10Mbps from the wired connection and when I bypass it I get 18Mbps (what I pay for). The strange thing is that when I update the firmware or reset configurations it gives me the whole 18Mbps, but as soon as I start to make more tests it drops to 10Mbps.

I installed the dd-wrt custom firmware and it happened again, first 18, then 10. I thought that after some time the cpu or memory could be heavily loaded but dd-wrt shows me that the cpu load is always at 10% and used memory is 40%.

Tried to switch cables. Having exactly the same problem with a WRT54G V8.

Is there something to do with the Router <-> Analog Telephone Adaptor connection?

My current firmware is DD-WRT v24-sp2 (01/02/10) mini - build 13575M NEWD-2 K2.6 Eko.

---- UPDATE ---

I tested the router using IPerf with 2 wired computers and got 80Mbps.

  • What do you mean by ATA in this context? I think the ATA tag is usually used for the mass storage bus, but I'm pretty sure the WRT160N doesn't have an ATA bus. Is ATA the name of your ISP or something? Or do you have a VoIP telephone adaptor (Analog Telephone Adaptor) involved in your setup or something? – Spiff Apr 25 '12 at 19:07
  • @Spiff sorry, I misused the tag, I meant Analog Telephone Adaptor. – Roberto Apr 25 '12 at 21:23
  • Can you describe "more tests" further? Any special configuration? Or does it just become slower after some number of connections or some amount of transmitted data? – Gurken Papst May 11 '12 at 18:50
  • @GurkenPapst It just becomes slower after some amount of transmitted data. No special configuration, I just keep using it and then it gets slow. – Roberto May 11 '12 at 20:35
  • Weird. And just rebooting DD-WRT does not restore the fully working state? Only restoring firmware defaults (or reflashing, which probably also resets the settings)? I have no idea, what could change permanently inside the router just by using it and only be fixed by restoring defaults. Is it possible to leave out the telephone adapter or replace it with other hardware? While I am doubtful that this will help, this still might be the best way to isolate the problem. – Gurken Papst May 11 '12 at 22:04

If you have several devices on your network, try transferring files between them (either by HTTP/FTP, doesn't really matter how, as long as you can see the speed). If the average is higher than the 10-18Mb/s you're getting the problem is the link between your router and the ISP; If you get the same decrease then the problem is on the router itself (and since you've tried DD-WRT it's probably a hardware issue).

| improve this answer | |
  • I updated the question with your suggestion: I get 80Mbps in this LAN-LAN transfer. Therefore, by your answer, the problem is my ISP link, but I cannot accept your answer because I get 18Mbps when I bypass the router and connect the computer directly to the ATA. – Roberto May 11 '12 at 20:43
  • Additionally, two routers with the same hardware problem? – Roberto May 14 '12 at 18:27
  • If it is a hardware problem, it's probably with the ATA-facing ethernet port. – jackweirdy May 14 '12 at 19:51

The WRT160N appears to be very similar to the WRT610N I bought. I have found numerous articles on the web describing problem with heat dissipation in these devices because of the shape of the device. In my case (and many other reports on the web) this causes complete drops of the Wifi connection.

Cisco support claims not to have received any such complaints and since I contacted them a month after the warranty expired I am out of luck. Until I get a new device I have rigged myself something to place the router some 6 centimetres up from the desk it sits on to improve cooling.

It is far less advanced than is described here. This guy built a complete cooling device for his WRT610N.

I imagine that if your device is overheating as well but not getting to the point where it fails that might explain why it is slowing down.

Here's one thread about such overheating problems.

| improve this answer | |
  • That's a good explanation, but I'm not having problems with wireless, all my tests were wired. And they are reporting loss of connection problems, I'm not having connestion loss. – Roberto May 12 '12 at 14:05

This might be a case of your ISP over-commitment of lines, meaning that the infrastructure cannot support the number of clients.

Interference in this case slows down the line speed soon after you connect.

| improve this answer | |
  • I don't think so, because I test with the router and then without and then with it again repeated times and get the same results. Also, I test many times for a considerable amount of time with the router and then without, to always get the same respective results. – Roberto May 18 '12 at 12:37
  • Then it may be that the interference is inside your home network. – harrymc May 18 '12 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.