4

When changing the keyboard layout in Windows 7 hitting Alt+Shift, LibreOffice Writer also changes the language of the text that I enter. No matter what language is set-up for the document, style, or paragraph, it switches to the language that matches the keyboard layout. I haven't found an option to switch this feature off. Do you know where I can find it? And is there any at all?

  • 1
    There's a bug report together with a discussion about this issue, dating from 2009. Since it's confirmed but still open, i fear that there's still no way to disable this behaviour. – tohuwawohu Apr 28 '12 at 7:08
  • 1
    Thanks for the link. Looks like the developers are rather ignorant of this problem. I assume the solution is to switch to MS Office. – Wolfgang Apr 28 '12 at 13:05
  • @Wolfgang seems a bit strong a reaction for one bug. Albeit that it is an annoying one. – icc97 Nov 10 '15 at 10:42
2

This issue has been fixed in Libre Office v4.0. From the Libre Office forum: Writer: document language changes with keyboard layout - how to remove this behavior?.

There is a new setting to ignore the input language:

Options - Language Settings - Ignore system input Language

| improve this answer | |
-1

I am experiencing bizarre behavior from Libre Office as well. Besides switching language, the cursor jumps unpredictable, the arrow keys are reversed, it arbitrarily jumps to right-justified, and seemingly unending idiosyncrasies. So switching from this program doesn't seem as such a strong reaction. I'd love to stay with open source, but the bugs are so bad that work is impossible.

| improve this answer | |
  • This does not answer the author's question. Please considering editing your question so it specifically answers the author's question. Please consider the fact that commentary should never be submitted as an answer. – Ramhound Jan 24 '17 at 15:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.