I was trying to open cisco.com in Google Chrome and got an error something about

this site is on several servers and I cannot make requests to several servers

Today I got another error with a Google picture of a broken robot that Google cannot handle this request. Why Google? I entered "cisco.com" without spelling errors.

Then I tried to do the same on Firefox – it just worked. Then I got the error:

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request

… in Google Chrome. Now I get a redirection to http://www.channelintelligence.com/ in Chrome as well, however the site works on FireFox. What is going on? Does Google try to control all my browser requests (but cannot handle this properly)?


Try clearing the browser cache (Settings -> Show Advanced Settings -> Clear browsing data).

Clear it "since the beggining of time" and restart the browser. You could even go further and delete the user data directory. WARNING: this will delete all your browser settings. But it's worth it if you want to resolve this kind of issues and start over with a clean slate.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.