My Eee PC (ok, not mine ... my friend's) is suddenly stalling in the grub bootloader . It was running Ubuntu. He says "nothing changed" but I'm not totally convinced because that makes no sense.

I have RIP Linux on a USB stick, ideally, I'd boot to that, but I can't seem to get into the bios. The Eee boots as far as a OS selector and no amount of esc or f2 will stop it at the bios first.

Neither Eee PC won't boot from USB nor Boot from USB using GRUB has helped. Doing root (hd tab (per these instructions and these) shows three hd0 filesystems: ntfs, fat, and an "unknown file system" -- fat boots the Windows rescue partition, ntfs boots to the OS choice menu, unknown just hangs. From the OS choice menu, Windows XP boots fine, choosing Ubuntu Netbook loads GRUb. Tried root (hd1) but Grub "can't get C/H/S values." (Help with grub commands like chainloader via these instructions)

Stalling startup at OS Selection gives a f8 option, which gets this:

Windows Advanced Options Menu
Please select an option:

  Safe Mode
  Safe Mode with Networking 
  Safe Mode with Command Prompt 

  Enable Boot Logging 
  Enable VGA mode 
  Last Known Good Configuration (your most recent settings that worked) 
  Directory Services Restore Mode (Windows domain controllers only) 
  Debugging Mode 

  Start Windows Normally
  Return to OS Choices Menu

  Use the up and down arrow keys to move the highlight to your choice

but there's no bios option there either. So what next?

  • Okay, so holding down <kbd>f2</kbd> while turning the laptop on did get me into the Bios. So I've got RIP linux. If anyone has answers about navigating the bootloader, I'm all ears.
    – Amanda
    Commented Apr 30, 2012 at 13:06


You must log in to answer this question.

Browse other questions tagged .