Sometimes, maybe about 1 in 5 times, when I startup my laptop, there is no sound. I don't mean the startup sound doesn't play, no sound plays after that. If I go into the sound settings in the control panel, my speakers are enabled. However, when clicking the sound slider in the volume control in the taskbar, there is no green level indicating the beep being played. If I disable the speakers in the control panel and then reenable them, the level appears when I click the slider, but still no sound is played. Running the Windows audio playback troubleshooting returns no errors.

The Windows Audio and Windows Audio Endpoint Builder services are running in the services menu, and I restart them to no effect. I'm running the Realtek High Definition Audio drivers and according to Window they're up-to-date.

If I disable and reenable the speakers enough times in quick succession it seems to work, however this varies; sometimes it works after a couple of iterations, other times, after 50 or so iterations I give up.

I'm at my wits end. I've been trying to solve this problem for about a month and I don't know what to do at this point; I've done everything I can think of, so thanks in advance for your help.

EDIT: I just wanted to say that this didn't happen when I first bought the laptop, so I can only imagine it's something I've installed or tinkered with.

  • Have you updated your laptop's BIOS? – ta.speot.is Apr 30 '12 at 11:45
  • No, but I just checked and there's a new one out for my laptop I'm downloading now. The problem is, is that it's really very difficult to test if it solves the problem because I need to restart and that fixes the problem anyway. – Ben Elgar Apr 30 '12 at 11:53

Did you get the latest drivers from the Realtek website? They are usually more up to date than those from Windows Update or your motherboard manufacturer.

  • No, I didn't check there. I just checked my manufacturers website and there's an update from the middle of last month, so I'll download that now and get back to you when the 170MB download is done. Which on my connection might be sometime tomorrow. – Ben Elgar Apr 30 '12 at 11:52
  • Sorry, I didn't get back to you. Which I feel kind of bad about, however that does seem to have done the trick! Thanks! – Ben Elgar Jun 13 '12 at 13:29
  • No worries. Glad everything worked out. – Ariel Jun 15 '12 at 1:48

I had the same problem with my laptop, and it was all the time, no sounds until I put it to sleep and wake it up, the problem was in the audio settings, i went to "audio manager > device advanced settings" there were an option for the recording device, whether you choose it "tied with line in" or "separated", i choose the second, now it works fine at start up.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.