I'm unable to install or remove any software package on Ubuntu. No matter how many times I try "apt-get -f install'.

jeroen@jeroen-panda:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 404 not upgraded.
38 not fully installed or removed.
Need to get 0 B/1,794 kB of archives.
After this operation, 4,571 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 104411 files and directories currently installed.)
Unpacking gstreamer0.10-plugins-bad (from .../gstreamer0.10-plugins-bad_0.10.22-2ubuntu4+ti1.5.4.7+1_armel.deb) ...
dpkg: error processing /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-2ubuntu4+ti1.5.4.7+1_armel.deb (--unpack):
 trying to overwrite '/usr/lib/libgstbasecamerabinsrc-0.10.so.0.0.0', which is also in package gstreamer0.10-plugins-good 0.10.30-1ubuntu7
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

This is worse than Windows! One broken package, breaks your entire distro...

  • What exactly did you do to end up here? To my understanding libgstcamerabin.so isn't even supposed to be in that package. May 1, 2012 at 13:03
  • "dpkg: error processing …_armel.deb" - This is an ARM architecture computer right? May 1, 2012 at 15:54
  • Probably no point, but just try a reboot followed by 'sudo apt-get update' and then tru the installation. Also, AskUbuntu.com may be more appropriate
    – Akash
    May 1, 2012 at 16:26
  • Hi, yes this is an ARM pandaboard. I tried to install the "cheese" package, to get a webcam working. Anyway, no harm done if I need to reinstall it, so maybe that's just the easiest solution. May 1, 2012 at 16:32
  • Did you tried to run an apt-get update and then an apt-get upgrade?
    – Ivan
    May 2, 2012 at 13:25

1 Answer 1


Sounds like your upgrading is stuck because of a stray package. Run this command in a terminal and see if that fixes your problem:

rm -rfv /usr/lib/libgstbasecamerabinsrc-0.10.so.0.0.0

I am just a little puzzled because this bug was already fixed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .