11

Recently my Chrome no longer checks my spelling. The "Enable spell checking" is checked on, but the spell checker does nothing. It does not check spelling, there is no suggestions for any word I type in a textbook, and the right-click menu item is grayed out.

I tried to uninstall and reinstall, but the problem persists. Also I find that the folder C:\Users\XXX\AppData\Local\Google\Chrome\Application\Dictionaries is empty. Could anyone point to a possible solution?


EDIT: I found out the reason for my issue. It is actually the Great Firewall in China interfering with the download of dictionaries. But given the answers below, there are many different causes of the same phenomena, so I won't mark any answers as "accepted" and leave it for the readers to decide what applies to them.

4

If you are using the option "Ask Google for suggestions" it seems to break everything. My spell checker came right back on as soon as I turned that option off. It's frustrating because my spelling is so bad that's the only way it knew what I was trying to spell half the time. :)

|improve this answer|||||
2

Here's what fixed this for me in Chrome 52:

  1. Right click in a text area
  2. Go to Spellcheck -> Language settings
  3. Click on the default language
  4. Make sure there's no problem with the dictionaries.

In my case, I had to download dictionaries again, after which spell checking resumed working.

|improve this answer|||||
2

There are spell checkers for specific accents only.

Instead of "English", you could add "English (US)" or "English (UK)" and enable the spell checkers for them.

Reference:

[1] https://productforums.google.com/forum/#!topic/chrome/rtHvzsF7oR4

|improve this answer|||||
  • 1
    This should be marked as the answer for this problem. – Tom John May 31 '19 at 14:38
0

This solved it for me, after months and months of suffering and searching for answers everywhere with no luck, until this, from deepdarkocean:

i am not sure how to explain it but write a word then select it (like you were going to copy it) double click on it on trackpad, it shows a checkspell option, hover over it and it has a "check the spelling of text fields" option, then just click it, & a little check appears next to it & ta-da it works! if youre unable to do/find this, please tell me & i will upload pictures

|improve this answer|||||
0
  1. Type some text
  2. Select a word in the text
  3. Right click the selected word for popup menu
  4. In popup menu: Spell check -> Use enhanced spell check
|improve this answer|||||
-1

Try copying the contents of the Dictionaries folder from some other PC's Chrome installation. Or just reinstall Chrome. Pretty harsh, but I don't think it can be repaired any other way.

|improve this answer|||||
  • 1
    "tried to uninstall and reinstall, but the problem persists.." – Sathyajith Bhat May 3 '12 at 10:28
-2

The general 'English' (without a country) does not have a spell-check option so you must add your country's English and move it to the top of the list. Thanks to Mr. Ree - His solution was the one that solved this problem for me.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.