2

How to play .smi format subtitles with VLC player 2.0.1 ?

The player is reading the .smi file but the subtitle text displays in special characters .

1

You need to set the correct encoding for .smi subtitles. Go to Tools > Preference > Subtitles and set the correct encoding, depending on the language of the subtitle.

| improve this answer | |
0

Try opening the .smi file in a web browser such as Google Chrome. Adjust character encoding so the characters show up correctly. Copy the content into a text file and save with .smi extension.

| improve this answer | |
0

Try turning off the Kate Overlay Decoder. To do this, Tools -> Preferences, then at the bottom of the window, Show Settings (All). In the left list, choose Input Codecs -> Subtitle Codecs -> Kate and uncheck the box on the right hand side.

| improve this answer | |
0

Easy way to play .smi format subtitles is to convert it to .srt file.

  • Use subtitleEdit software.
  • Open the software, then file> open> (choose the smi file).
  • Then file> save as> rename it as .srt file and save it.
  • Your .smi file is converted to .srt file. Now you can play it easily.
| improve this answer | |
0

How to get korean or other region subtitles working with VLC. The problem is because Unicode fonts on Windows are not installed by default, however on mac they are. These steps works with both Windows 10 and macOS (OSX):

Go to VLC -> Preferences -> Subtitles/OSD.

1) Set default encoding to the one that is reported by Notepad++ at the bottom right. 2) Set font to "Arial Unicode MS"

In Windows 10 you have to install then manually, the fonts are copyrighted. Microsoft Office and other software install them depending on the program and version. On OSX they in "/Library/Fonts/Arial Unicode.ttf"

https://en.wikipedia.org/wiki/Arial_Unicode_MS

Additionally, you can leave the default encoding to your local or default setting and convert the SMI file to UTF-8-BOM with Notepad++ for example. That way the UTF8 with BOM already has the encoding inside.

Example to test: https://trac.videolan.org/vlc/ticket/17257

Search too for malgun gothic or batang or gulim fonts.

Check here more information on the issue: https://office-watch.com/2002/wheres-arial-unicode-ms/

| improve this answer | |
0

1 Open VLC 2 VLC, Preferences, Subtitles/OSD 3 Change default encoding to Korean (EUC-KR/CP949) 4 Install Noto sans font on your computer. 5 Change font to Noto Sans (Korean version) 6 Done :) Enjoy

Download Noto Sans font: click here

how to read .smi file format with vlc

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.