I "upgraded" to Ubuntu 12.04 over the weekend. tsclient (terminal server client), which I used to use all the time here at work, is gone. It was replaced by Remmina, which is terribly unstable and buggy.

Does anyone know how to get tsclient installed on Ubuntu 12.04? How do I get tsclient back?

  • start to use remmmina. It's part od 12.04 and much better than old tsclient.
    – tigran
    May 3, 2012 at 21:23
  • 1
    I have been using remmina and it is not much better. It crashes, the clipboard doesn't work, the num lock key is backward and the shortcut keys are screwy. tsclient may be old, but it worked great! May 3, 2012 at 21:37
  • Drake, how do I get rid of Unity and get back to a desktop that works? May 3, 2012 at 21:38
  • 1
    Also, after you install gnome-panel on 12.04 you'll have the option to log into gnome and gnome classic
    – amotzg
    May 6, 2012 at 14:33
  • 1
    duplicate of askubuntu.com/questions/131042/…
    – cweiske
    Jun 8, 2012 at 9:55

5 Answers 5


You can try grdesktop. It is also a GNOME frontend to rdesktop.


One possible way that I could think of to install tsclient is to download the package meant for previous release and installing it manually. But, be warned that it could break your apt and create dependencies problems among others.

Anyway, download the tsclient package and the relevant dependencies from packages.ubuntu.com.

For a typical 64-bit architecture, the following command would install tsclient for you:

sudo dpkg --force-all -i tsclient_0.150-4ubuntu2_amd64.deb

For 32-bit system:

sudo dpkg --force-all -i tsclient_0.150-4ubuntu2_i386.deb

Install tsclient in Ubuntu 12.04 LTS

The best client to use rdesktop is tsclient. No doubt!

Remmina is terrible (buggy)!

grdesktop works, but does not have the same features as tsclient (share your folders automatically on the remote computer, for example) and his aesthetic is horrible.

Due to the long time without updates tsclient is increasingly difficult to be installed on Ubuntu.

But the good news is that tsclient works perfectly in Ubuntu 12.04 LTS! To make it work without being bothered by the Ubuntu package manager do what I explain here.

Download the package tsclient (0150) for the desired architecture (64 or 32 bit) from http://pkgs.org/

Install the package using --force-all to ignore dependencies.

sudo dpkg --force-all -i tsclient_0.150-4ubuntu2_amd64.deb

This package will be installed with the status "broken". If this situation continues the tsclient will be removed in the first update or update will not work or Ubuntu Software Center will not work.

The actions to repair Ubuntu Software Center suggested by Ubuntu also remove tsclient

To change the broken status of tsclient do the following...

Source: http://www.sudo-juice.com/ignore-broken-packages-ubuntu-aptitude/


Ignoring broken packages in Ubuntu or any other distribution of Linux using Aptitude package manager would usually be a bad thing and it’s not recommended. Maintaining a system of broken packages kind of defeats the object.

BUT, I recently came across a situation where I had to install a 32bit version of Chrome on my 64bit Ubuntu. I did this by completely removing previous versions of Chrome, then downloading the .deb file from the Chrome download page and installing it from command line using….

sudo dpkg --force-architecture -i google-chrome-stable_current_i386.deb

This worked.

So why the need to ignore broken packages?

Well though it worked, it left some dependency issues. The dependencies are installed, but because they are working in a sort of compatibility mode (MultiArch) they show as broken dependencies. This forces Synaptic to display it as broken package every time you try to update, not only display it as broken but prevent you from updating until you fix it. Synaptic's fix is to completely remove it.

Ok then, How do I force Synaptic to ignore the ‘broken’ package?

Firstly you have to find the dependencies that are causing the errors:

Open Synaptic Package Manager (you may need to install this first “sudo apt-get install synaptic“) Find the ‘broken’ package, you will probably be notified there is broken package – click the link to Broken from the list on the left of the screen – make a note of the package name Right click on the package, select Properties Go to the Dependencies tab, make a note of the dependencies listed in italics Leave Synaptic open to test the fix later Now we need to edit a file. Open a terminal and type/copy:

sudo gedit /var/lib/dpkg/status

This should open the file status (which can be pretty long), you now have to find the package name (Ctrl+f should help). There should be a little section for it that resembles this:

Package: google-chrome-stable
Status: install ok unpacked
Priority: optional
Section: web
Installed-Size: 119100
Maintainer: Chrome Linux Team <chromium-dev@chromium.org>
Architecture: i386
Version: 22.0.1229.94-r161065
Config-Version: 20.0.1132.57-r145807
Replaces: google-chrome
Provides: google-chrome, www-browser
Depends: libasound2 (>> 1.0.22), {...and many others!...}, libcurl3, wget
Description: The web browser from Google

Now delete the dependencies (the italic ones you noted earlier) from the Depends line, save the file (Ctrl+s) and close.

Editor note

In our case just remove the "libpanel-applet2-0 (>= 2.26.0)"

How do I know if my "broken" packages are being ignored?

Now click Reload in Synaptic. You shouldn’t receive the broken dependency message you did earlier.


The only problem I ran into with ignoring broken packages were updates. I had to update chrome which involved doing this again (because I had to completely remove it in the first place!).

Like I said before, I don’t condone ignoring broken packages, or anything broken for that matter! Sometimes these things have to be done though.

To prevent tsclient to be removed in future updates do the following...

Source: https://askubuntu.com/questions/18654/how-to-prevent-updating-of-a-specific-package

Install synaptic using sudo apt-get install synaptic.

Run using gksudo synaptic and on the search box locate the package you want to lock, ie: gedit

From the package menu select Lock version:

And that is all, the version currently installed at the time of the lock will stay installed even during upgrades.

That's all folks!


rdesktop is still available and if I recall right, that's what tsclient depends on. (sudo apt-get install rdesktop)

And yes, remmina is not good at rdp atm.


I know how you feel. My key bindings are all over the place with remmmina and I keep on getting unity popping up now and again. I've reverted to tsclient ...

Download tsclient from http://packages.ubuntu.com/natty/tsclient and installed the usual way. The missing libpanel-applet2-0 dependency is not really needed so the force all option worked for me.

For 64-bit arch:

sudo dpkg --force-all -i tsclient_0.150-4ubuntu2_amd64.deb

For 32-bit system:

sudo dpkg --force-all -i tsclient_0.150-4ubuntu2_i386.deb
  • Your answer is nearly identical to @jokerdino's answer.
    – JoshP
    Sep 27, 2012 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.