I have strange problem with the recycle bin icon on my Windows 7 system. I can't enable it in the "Desktop icon Settings" window by checking the checkbox to show it, because this option is unavailable.

Enter image description here

How do I fix this problem?

  • What version of Windows 7 are you running?
    – Amicable
    May 4, 2012 at 8:25
  • Version 6.1(Build 7601:Service Pack 1) May 4, 2012 at 8:28
  • I meant Home/Professional/Ultimate? At least you are patched to date though.
    – Amicable
    May 4, 2012 at 8:31
  • ok it's Professional version May 4, 2012 at 8:34
  • and all patches are installed too May 4, 2012 at 8:51

1 Answer 1


Hope This post will help you , please try it.

Recycle Bin option is unavailable in Desktop icons settings box, you need to enable it via Windows Registry by following the steps given below:

enter image description here

  1. Download Restore Recycle Bin Registry file.

  2. Right-click on the file and then select Open.

  3. Click Yes for the prompt. enter image description here enter image description here

  4. Now click Ok. Reboot your machine to see Recycle Bin on your Desktop. Note that this will also enable Recycle Bin option in Desktop icon settings box.

  • thanks Desingh, it works great! But when i execute script it not update Windows Registry, after that i update it manualy. May 4, 2012 at 14:30
  • 1
    @IshikawaYoshi - If it didn't update the registry for you then it didn't have permission to do so. The script work fine on a virtual machine I tested it on.
    – Ramhound
    May 4, 2012 at 14:46
  • hm, sorry i don't know why it not work first time, but i tested it now and it works fine. thnx again May 4, 2012 at 14:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .