I'm having problems running Event Viewer (wherever I open it, a "unable to create snap-in" error pops-up, the error details something as CLSID: FX:{b05566ad-fe9c-4363-be05-7a4cbb7cb510}) and other applications, such as Zune (fails to open everytime, since right after the installation) or Visual Studio (had to install it and remove it a few times, had an issue with AddInUtil.exe if I recall correctly).

I think I figured there is a common cause, which is .Net Framework, which somehow screwed up. It could have happened when I last tried to update Windows7 to SP1, the update failed and the system would lock to a black screen as soon as I would turn on my notebook. I fixed it using System Restore (tried again another time, got the same mistake).

Some more information:

  • I'm pretty sure my system is clean, I scanned it twice with avast (full and in-depth scan, of course), tried to reinstall it just in case, made a boot scan.. so here should be no things such as malwares, viruses, trojan horses..
  • I already tried sfc /scannow, I think it fixed some things but if I launch it again it says there are no problems to fix
  • I know the Event Viewer issue is sometimes connected to a mmc.exe.config calling a wrong .Net Framework installation, but there is no such thing on my system
  • I tried going on "Turn Windows features on or off" in Control Panel, .Net Framework is an half-checked square (the square is full, there is no check on it). If I try to enable all the features and confirm, it will stay idle for a while, then an fault error window pops-up, saying it was unable to turn some features on and prompts me to reboot. After the reboot nothing changes, the square is still half-checked.
  • I also tried running the .NET Framework verification tool: it turns out there actually are some issues in my .NET Framework 2.0 and 3.5 installations ("Product verification failed"). The only errors I can find in the logs are some missing .nlp files (such as big5.nlp, normnfc.nlp, normnfd.nlp, prcp.nlp, sortkey.nlp, xjis.nlp)

Anyone got an idea? As you can see I tried pretty much everything.. Apart from the program issues the system works just fine, but it sucks to be without Event Viewer (it's one big useful thing) and I need Zune for some things, so I'm getting pretty tired of the situation (but I wanted to see if there is a way to fix this without reinstalling the whole system!)

  • use a restore point? shouldve been one auto created before sp1 install. – Robert Kerr May 5 '12 at 16:31
  • that's how i fixed the broken SP1 installation, but the Event Viewer still won't work. And another thing, there weren't so many restore points: IIRC there was only one or two before the installation (where are the good XP times when you could go even months "back in time"? and another thing i'd like to point out - i'm not completely sure it was the SP1 installation to break things: that was just when i noticed something was very wrong.. – LightRay May 5 '12 at 23:57

Use the System File Checker tool (SFC.exe) to determine which file is causing the issue, and then replace the file. To do this, follow these steps:

  1. Open an elevated command prompt.

    • Start → All Programs → Accessories

    • right-click on Command Prompt, and then click "Run as administrator"

    If you are prompted for an administrator password or for a confirmation, type the password, or click Allow.

  2. Type the following command and press Enter


    This command scans all protected system files and replaces incorrect versions with correct Microsoft versions.

More info about the System File Checker in this Microsoft KB article.


You can uninstall the various versions of the .NET Framework from the Control Panel, like any other program. Then download and install the most current version from http://www.microsoft.com/net/download. If that doesn't fix the problems, then the .NET Framework is probably not the issue.

  • and the problem is: i don't have any .NET Framework in my Control Panel, i think i removed everything during the last unistall of Visual Studio (maybe we figured out the problem? but i'm pretty sure Zune wasn't already working at that point) reinstalling the Framework was the first thing that came into my mind, the problem is: i couldn't find a Windows 7 installer of .NET Framework 3.5 (XP only, maybe Vista too) and installing version 4 didn't fix any problem – LightRay May 6 '12 at 0:00
  • If you have .NET Framework 4 installed, then the .NET Framework is not the problem. Microsoft states at bit.ly/IPYsQK that "The .NET Framework 4 is backward-compatible with applications that were built with the .NET Framework versions 1.1, 2.0, 3.0, and 3.5. In other words, applications and components built with previous versions of the .NET Framework will work on the .NET Framework 4." If you agree, I would appreciate your accepting my answer! – Dave Becker May 6 '12 at 4:27
  • yeah, and i can confirm that: i just reinstalled Visual Studio Professional again, and that came with .NET Framework 4. But still, Event Viewer nor Zune would start. I can't accept that as an answer because, in fact, it didn't fix my problem (but i gave a +1 because you where helpful in moving in other directions). If you could give me a hand to figure out what's wrong, i'll be more than happy to give you kudos :) (maybe some hidden conflicts between version 4 and version 3.5 leftovers?) – LightRay May 6 '12 at 16:44
  • You might try the .NET Framework cleanup tool - blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx - to be sure that's not the issue. If that doesn't help, then I don't think the problems have anything to do with .NET Framework. – Dave Becker May 6 '12 at 18:55

Just to give a few clarifications to previous comments. Applications dont automatically roll forward to .NET 4.0 from .NET 3.5 so if you have something that depends on .NET 3.5, you need it installed or you need to add an application config file to the application that will tell it to run on .NET 4. Also, you wont find an installer for .NET 3.5 on Windows 7 because its built into the operating system.

The guid you mentioned in your error FX:{b05566ad-fe9c-4363-be05-7a4cbb7cb510} corresponds to eventviewer.dll so it makes sense you are seeing that when launching event viewer.

What would probably be handy is to run procmon on the machine and capture all the output for the process to see what exactly is happening at the time of the failure.

If you want to email me the procmon trace, I can try to take a look at it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.