I have about 11 gigs of content on SkyDrive. When the new Windows client was released a couple of weeks ago, I downloaded and installed it, specifying a location on my D drive for the local copy. That was over a week ago, and only about a third of my folders have synchronized to my local PC. (The folders were copied, and any internal folder structure was maintained, but the folders and subfolders are empty, and the "syncing" icon displays on the folders.) I leave this machine on almost all the time.

I've looked through the client settings, but there doesn't seem to be a way to force the refresh. I never had this problem with Mesh, which synced the files immediately. Does anyone have any ideas?

  • This is a complete guess, but, I suspect that the file tracking software in the client is somewhat unstable and has problems tracking large numbers of small files. I encountered the same problem and had to add in groups of files - it sucks but fixed my problem. Once the files are synchronized everything works like a charm.
    – Kane
    May 17, 2012 at 13:25
  • I have the exact same issue. Some files sync, some don't. No rhyme or reason to it.
    – Dana
    Jun 5, 2012 at 21:31
  • I was experiencing the same issue when I tried to sync files between my PC and my Macbook. I resolved the issue by restarting the skydrive client on both sides.
    – HelloWorld
    Oct 30, 2012 at 20:23

11 Answers 11


Just as a follow up, this problem went away on its own a couple of weeks later. This question was entered almost immediately after the SkyDrive tray app was released, and they probably fixed the problem with a subsequent update.


I jumped on Skydrive for the first time last week (July, 2012) I have 7 computers syncing with Skydrive. Only 2 - 3 gigs at this time. After a few days, I saw that each computer was syncing with skydrive.com, but stopped syncing with each computer.

I believe that when I created a network share for x:\cloud\skydrive folder, it stopped syncing with each other. I removed the network share but it still would not sync.

I remotely connected to each computer, exited skydrive and verified on skydrive.com that the connection was lost for each computer. Then I double-checked that the skydrive folder was not shared and restarted skydrive on each computer.

Within a few minutes, each computer started syncing with each other.


I've found that it's usually a file permissions thing. If the file doesn't have the correct permissions, they won't sync, and it won't tell you why. I've lost countless files like this, to both Dropbox and SkyDrive. Irritating.


the solution to it is to remove the tick mark from uploading files in batches. Right click on your skydrive icon then click on settings, then click on the Performance tab, then remove the tick mark. then right click again on your skydrive icon, then click on exit. After that restart your skydrive and the problem is solved.


Interesting, have you tried reinstalling the SkyDrive client? Could you try exiting SkyDrive (right-click the icon in your taskbar, then choose "Exit"), then starting up Process Monitor (http://technet.microsoft.com/en-us/sysinternals/bb896645), setting an include rule for SkyDrive, then starting up SkyDrive again? If you check the areas on the disk it's accessing/writing to, you should be able to see what file it's working on. Other than that, I guess just try reinstalling it.

  • I tried that... it doesn't seem to be writing at all. When I hover over the icon in the system tray, it always says "downloading 0.0 of 10.7 GB". I'm stumped... guess I'll try reinstalling.
    – Roger
    May 7, 2012 at 2:33
  • weird, hopefully reinstalling fixes it
    – MatthewSot
    May 10, 2012 at 0:18

seems the skydrive process hangs. I attempted to just close skydrive and start it up didn't work. My fix is to start up task manager and kill the skydrive process and then start skydrive backup it backup again


On the Windows 8 Skydrive window, the "last updated" date for a given file does not change when I change the file but it does update when I press the "refresh" button at the bottom of the window.

  • 1
    That's not what the OP is asking, is it?
    – BenjiWiebe
    Feb 21, 2013 at 2:54

I had the same problem, and it turned out there was a nifty feature that I didn't know about to allow some but not all folders to sync on a given computer.

Right click on the Skydrive tray icon, select Settings > Choose Folders > Select the folders you want. I wasn't seeing all my folders because I hadn't selected all of them to sync.

Not quite as nice as Live Mesh's implementation of peer-to-peer syncing without having to upload everything to the cloud, but I digress :)


The only prob I have had is with the naming of files. I use more than one OS and bring files into Windows. That may be an issue some have.

Whatever the prob is if you right click on the update center and open it (orange icon with an arrow in your task bar) then read the error messages you should be able to solve the conflicts manually (there is a drop down menu to resolve conflicts).

This is not like dropbox it is a bit more careful as generally these are business documents. I don't think it wise to think of sky drive as dropbox by Microsoft. Dropbox is for any old crap - skydrive is a hook to 365.


I don't know if anyone else is still experiencing problems with this, but I was. I tried everything listed above and it would still showing the syncing icon and show uploading....yada yada yada. It just wouldn't sync anything. Even stopping the app and restarting it wouldn't work.

Finally I un-installed it completely, then reinstalled it, and everything was synced and hunky dory.

The only thing I can think that might of caused was this I installed it recently on another computer. Maybe the different versions are causing a conflict.. ??

Anyway, I hope this helps someone else.


I found a solution to lost files that won't upload.

If you search your computer for "Skydrive Old", you'll find a folder that has everything you ever put into your skydrive folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.