Last Thursday (03/05/12) I got a new computer to be able to work from home. I plugged it, by cable, into the company network and installed most of the software needed for me to do so, by accessing a share on my stationary computer at work. I had no issues here what so ever, and everything just worked.

Yesterday evening I tried accessing the company network trough Windows VPN, and while I was able to connect to the network, I was unable to connect to any computers on the network. I did, however, get an error when connecting, but I can't seem to get the error again, to get the details of the error message.

Today I am sitting on the company network again, and now I can not access anything on the network like I could last Thursday, though I can ping all the computers I am attempting to access.

Here is a list of details that might help in troubleshooting this issue (updated):

List of observations / actions

  • My computer is identical to another computer that has no issues.
  • It is not on the domain but rather on the default workgroup, but this was not an issue last Thursday, so I am assuming it still is not.
  • I am able to access my e-mail on the exchange server.
  • I can connect to our TFS server from Visual Studio but not from Explorer.
  • I can also connect to Database Servers and Remote Desktop.
  • I can see several computers when browsing network computers, but I am unable to connect to any of them.
  • When trying to connect to a computer I am consistently met with the error code "0x80070035" (network path not found).
  • I also get the 0x80070035 error when double clicking the target computer from the Network UI.
  • I am not met with a login dialog when trying to access a computer, as I should, since I am not on the domain. (I did login to both Exchange, Remote Desktop and TFS though)
  • Between Thursday where it worked and Sunday evening where it did not, I have installed quite a few security updates, plus various tools etc. that I need for programming.
  • I have tried accessing by computer name and ip and neither of them work.
  • I can ping by computer name.
  • I have deleted all (1 entry) stored network credentials.
  • I am able to access my computer from the target computer.
  • Client and Server can see each other on the network = Network Discovery is enabled.
  • I am using the network profile "Work".
  • When accessing the network through VPN, I am unable to get anything to work using computernames, but all of the above applies when using IP adresses instead of computername.
  • I run Windows 7 Home Premium on my computer.

Using powershell attempting to access a share I get the following error (ComputerName and ShareName being correct values of course):

PS C:\Users\MyUser> cd \\ComputerName\ShareName
Set-Location : Cannot find path '\\ComputerName\ShareName' because it does not exist.
At line:1 char:3
+ cd <<<< \\ComputerName\ShareName
    + CategoryInfo : ObjectNotFound: (\\ComputerName\ShareName:String) [Set-Location], ItemNotFoundException
    + FullyQualifiedErrorId : PathNotFound,Microsoft.PowerShell.Commands.SetLocationCommand

However, ping'ing the same machine (ping ComputerName) from powershell I get response immediately.

(As mentioned in the list of observations/actions, I tried the above with the IP address again on VPN, to get the same result)


So to sum up, pretty much the only thing I can not do, is access the other computers through browsing (explorer.exe, powershell, map networkdrive, etc.), which means that I am pretty much down to, that it is unable to resolve the path somehow, when trying to connect to other computers trough browsing, though the path gets resolved perfectly using all kinds of other services.

Any recommendations as to what I can try next to resolve the issue? :)

  • You can probably find a solution in the other questions on not being able to access a Windows network share. It's either a firewall problem, or the protocol is not enabled on the interface, or some service is not started, or network discovery is disabled for the connection profile, or you're on a wrong subnet/vlan.
    – billc.cn
    May 7, 2012 at 11:32
  • @billc.cn I tried to be rather thorough in finding other related problems, and I might have missed something, but my main concern is, that this worked less than a week ago, without any modifications to the computer I am primarily trying to access. Thus, I ruled out network discovery, firewall issues, wrong subnet/vlan and a bunch of other issues. Most threads have solutions with corrections on the server computer, but I can not see how this can be anything but on my computer (client). I do not know which services might be missing on the client machine though. May 7, 2012 at 11:44
  • All the issues I raised can be affected by external changes (like administrator actions) or configured by the OS/software automatically when it detects you're on a different network. You may not have to do anything explicitly to break a piece of software these days. (And frankly you can't even check which vlan you're on yourself; how could you rule it out?)
    – billc.cn
    May 7, 2012 at 11:58
  • @billc.cn, that was also why I mentioned my presumptions in reply to your comment, because I could not see how it could be any of these things, but I will have to go them over again then, if the changes can be applied automatically like you say. May 7, 2012 at 12:21
  • Did you selected your network as "Home/Office network"?
    – crea7or
    May 7, 2012 at 18:06

3 Answers 3


As I understand you are unable to access shared folders on other computers. Try completely disabling windows firewall for all profiles and see if you can browse the pc's. If you have some antivirus or firewall software, also try disabling it. Check your file and print settings in network and sharing center - > advanced sharing settings.

  • This has nothing to do with security software.
    – Ramhound
    May 7, 2012 at 11:15
  • @Ramhound: In my experience win7<->win7 communication has never been a windows firewall issue either. And I do not have any security software except a simple virus scanner, so no, I can not see how it has anything to do with security settings like that either. May 7, 2012 at 11:49
  • Thanks for the answer though, it made me check my sharing settings, and got me to try something I had not so far (disabling the default way of accessing a homegroup, and let me use useraccounts and passwords for the conennections instead), but this was sadly also a dead end. May 8, 2012 at 7:02

I finally found out what caused this!

I was using an old "perfomance boost script" which added some changes to the registry, and among them were these two: (WARNING: These are examples of what NOT to do, it is NOT the solution)

;Disable Background Intelligent Transfer Service (default is 2)

;Disable TCP/IP NetBIOS Helper (default is 2)

I'm not completely sure which of the two caused the error, but both settings should not be disabled when you are on a domain network.

I have never found anything in the event logs or anything like that though, so it was only trough trial and error on a clean install that I finally found what was causing it all.


I've been through about 30 pages with no solutions, until I remembered Hyper V was the one other change I'd made. If there is an EXTERNAL Hyper-V Virtual switch, I can't get into other machines, if they even show on the network list. With Hyper-V virtual switch changed to an INTERNAL switch and after a reboot, all is well. In my case, also, pinging either the machine name or the IP worked fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .