1

I have a problem opening Excel 2007 documents in Excel 2010 where when I open the document, Excel gives me an error of "Current printer unavailable, select a new printer" and Excel presents a dialog window with all my printers, including my current default printer, which is an HP OfficeJet Pro 8000. If I select any printer besides the OfficeJet, Excel will take about 30-45 seconds, then open the document.

My computer is a Windows 7 x64 bit with Office 2010 Professional, fully updated. The person I'm receiving the Excel 2007 documents from is using Windows XP with Office 2007 Professional, fully updated, and this user also has an OfficeJet Pro 8000 as their default printer.

I've never seen this error before and I"m not having much luck Googling it. Any suggestions?

  • If this only happens with this one specific file, you might try copying the contents of the file to a new workbook. If that resolves the issue it was a corrupt file. If this error happens more than with the one file, try repairing your installation with your Office CD. – CharlieRB May 8 '12 at 17:03
  • It happens with multiple files, but not all and I've tried the Office repair on the Office 2007 workstation and the Office 2010 workstation. – Eric Feldhusen May 8 '12 at 18:44
  • What happens if you receive a doc, open it, select your printer and save it - does it then open normally? – hdhondt Jun 23 '18 at 0:59
  • Unfortunately, I no longer support either person, so I have no way of knowing. – Eric Feldhusen Sep 13 '18 at 19:37
0

I had the same issue. What fixed it for me was to switch my default printer to a different printer, and then switch it back.

You can switch your default printer in the Windows Devices and Printers pane. Right click on the printer and hit set as default printer.

0

Almost sounds like a macro, make sure you are NOT allowing any macros to run by default from that author, or in just general.

To check your macro settings go to: Microsoft Office Button, and then click Excel Options.

Click Trust Center, click Trust Center Settings, and then click Macro Settings.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.