I have a 3TB Seagate Barracuda disk (model no. st3000dm001). The disk contains data and uses ext3. I am using an external SATA enclouser via USB. I am trying to mount the disk using my ubuntu machine.

When I use fdisk; it issues the following warning:

WARNING: GPT (GUID Partition Table) detected on '/dev/sdc'! The util sfdisk doesn't support GPT. Use GNU Parted.

When using Parted, it shows this line

/dev/sdc (3001GB)

which hardly indicates that the disk is recognised with the right size but when I look for further details; parted return the following:

Error: /dev/sdc: unrecognised disk label

I would be grateful if someone points me to other resources or show how would I mount this disk.


Thank you all for your comments. The disk contains over 2.5 TB of data and I don't really know how it was copied so not sure whether that was using an enclosure, duplicator docking station or other means.

Using the command: parted /dev/sdc

GNU Parted 2.2
Using /dev/sdc
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) P                                                                
Error: /dev/sdc: unrecognised disk label

Using the command: cat /proc/partitions

major minor  #blocks  name

  8   32   2930266584 sdc

It is only one partition.

Using the command: sudo mount /dev/sdc /mnt/data

mount: you must specify the filesystem type

I thought that mount detects the filesystem type automatically but then explicilty specified the filesystem type in the following command

sudo mount -t ext3 /dev/sdc /mnt/data

mount: wrong fs type, bad option, bad superblock on /dev/sdc,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

So, dmesg | tail

[36374.712557] usb 2-2: reset high speed USB device using ehci_hcd and address 2
[36374.991045] usb 2-2: reset high speed USB device using ehci_hcd and address 2
[36375.273782] usb 2-2: reset high speed USB device using ehci_hcd and address 2
[36375.552576] usb 2-2: reset high speed USB device using ehci_hcd and address 2
[36375.830083] usb 2-2: reset high speed USB device using ehci_hcd and address 2
[36375.984427] sd 25:0:0:0: [sdc] Unhandled error code
[36375.984430] sd 25:0:0:0: [sdc] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[36375.984434] sd 25:0:0:0: [sdc] CDB: Read(10): 28 00 00 00 00 02 00 00 02 00
[36375.984444] end_request: I/O error, dev sdc, sector 2
[36375.984459] EXT3-fs: unable to read superblock

I couldn't figure out what is happening! is there something to do with gpt?

Further analysis:

using the command: sudo gdisk -l /dev/sdc

GPT fdisk (gdisk) version 0.5.1

Partition table scan:
  MBR: not present
  BSD: not present
Caution: invalid main GPT header, but valid backup; regenerating main header
from backup!
Warning! One or more CRCs don't match. You should repair the disk!
  APM: not present
  GPT: damaged

Found invalid MBR and corrupt GPT. What do you want to do? (Using the
GPT MAY permit recovery of GPT data.)
 1 - GPT
 2 - Create blank GPT

Your answer:

I don't want to accidentally wipe the data :) so better be sure about what options to try.

  • Please edit your question to show the exact command you used, and the full exact output.
    – psusi
    May 8 '12 at 18:34
  • what does parted /dev/sdc print say?
    – johnshen64
    May 8 '12 at 18:45
  • Have you had it connected directly to SATA before, and now you want to connect using a USB enclosure? You seem to imply that there is data on the disk that you want to access.
    – fstx
    May 8 '12 at 18:48

So, I am answering my own question! might be useful for someone.

I connected the disk internally through SATA and it worked fine. It seems the problem is finding a proper enclouser which can work with such disks.

Thank you all for your help.


You will need to find out how partitions and filesystems were created on this disk. You can do so with the following:

cat /proc/partitions

If you don't see any sdc partitions, then it is possible that the ext3 is on the entire disk.

Try to mount it.

sudo mkdir /mnt/data
sudo mount /dev/sdc /mnt/data

if that fails, then try partitions such as /dev/sdc1 etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.