4

I've spent all night working on this layout for a client and I'm 100% sure I saved my work — every 5-10 seconds of work I save.

That said. I open up Photoshop today to get some work done I notice that although my layers are there and named, they don't show on the document/canvas.

For example, if I have a text layer with red text, I select the layer and the color thing above in the property pane turns to the colors I gave all my headers — but the actual content (the text in this case) is nowhere on the page.

Keeping on with the troubleshooting, I hit Ctrl0 so I can see the whole document. Then I mouse over one of the layers layers that is acting weird, I mouse over the layer thumbnail, I hit Ctrl and click it so that it can auto select the content on that layers and again, nothing.

Any ideas as to what could be happening?

  • Does the appropriate image appear in the layer's thumbnail? When you hit Ctrl + T, does any bounding box show up (even off of the image canvas)? – Breakthrough May 9 '12 at 18:47
  • 1
    I'm guessing that you have an opaque layer at the top which is hiding everything behind it. Have you tried hiding all the layers and then unhiding them one at a time? – paradroid May 9 '12 at 18:48
  • @paranoid, yes i hid ALL the layers and one by one went turning them on/off and nothing. @ breakthrough, yeah no bounding box comes up. ive never had a problem like this b4. – somdow May 9 '12 at 21:04
3

This might be caused by bugs in your graphics card driver. Go to Preferences (Ctrl+K) → Performance and uncheck the "Enable GPU" option to see of that would help.

Updating the driver may also work.

  • 1
    This is not a bad suggestion, but I edited it to clearly state this is a case of it might being the case. Without knowing the full details on the original poseter’s system, there is no way to say this is definitely the case. Your suggestion and the other about layer settings are equally valid. – JakeGould Jan 14 '15 at 5:24
2

Check if layer filter is not activated (the little red square).

enter image description here

1

Did you use by any chance the "timeline" to create a gif?

I had the same problem. The layers were there but showed white on the canvas. Try opening the timeline option.

Go to Window > Timeline to open the Timeline panel.

Hope this works.

1

I had the same issue, even "Select Pixels" showed the outline in place, and no layer was above it. It turned out, the layer's opacity had been set to 0% for some reason... Not sure why I would have done that (or if I hit some shortcut by accident that caused it?), but bringing opacity back to 100% worked for my particular case.

0

In the layers box, the Red button is a toggle which hides and displays layers. Try clicking it if your layers have disappeared:

Red layer toggle button in photoshop

  • Why was this down voted? I'm not a Photoshop expert but this seems legitimate? – DrZoo Dec 29 '16 at 21:38
0

-> Windows
-> Workspace
-> Reset Pallette Location

I was trying to edit some text but my layer text was gone. The reset palette location brought all my layers back to the canvas. I must have accidentally turned layers off somehow.

  • 2
    While this may answer the question, it would be a better answer if you could provide some explanation why it does so. – DavidPostill Jun 9 '16 at 18:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.