2

In Windows XP if you have a problem with your RDC client license, you can delete the HKLM\Software\Microsoft\MSLicensing key to force the license to rebuild itself on reconnection. If you try the same thing on Windows Vista or Windows 7, when you try to reconnect to the server you get this message:

The remote computer disconnected the session because of an error in the
licensing protocol. Please try connecting to the remote computer again or
contact your server administrator.

and the MSLicensing key does not reappear in the registry. What causes this and how to avoid it?

2

The problem is caused by UAC in Windows 7 / Windows Vista. Because the RDC client does not by default have permission to create a new key under the HKLM\Software\Microsoft branch, it cannot rebuild the licensing information once it has been deleted! This causes a silent failure with the error message "problem in licensing protocol". (Ideally, the program would be redesigned to display a UAC challenge prompt in this situation).

To fix it, just run the RDC as administrator when you first reconnect to the target computer. This will allow the RDC client permission to rebuild the necessary registry keys. You should only need to do this once.

0

This problem made by some kind of caching of remote desktop licensing in clients you can solve this by remove the bellow key in registry:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSLicensing

It's much convenient to make a reg file and run it so .

  1. Make a empty text file
  2. Name it "mypatch.reg" or "mypatch.reg"
  3. Put bellow text in it and save it

     Windows Registry Editor Version 5.00
    
     [-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSLicensing]
    
  4. Run it by dubble click on file!

It should remove the key.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.