17

I would like to ask if you know how to fix a corrupted USB? I've tried the diskpart command but it didn't work. The media is write protected.

Do you have any idea that is much better? I need to fix it because I have important files in my flash drive. I really need to retrieve it.

I saw that the file system is seen as RAW and is unaccessible. I tried error checking, but it requires you to format it. I tried data recovery software but all files come out corrupted. My USB is Imation 4GB. Any suggestions?

15
  • Can you read anything from flash drive? What happens if you try to dd if=/dev/devNodeForDisk of=~/flashdrive.img from Linux # shell? Does it read any bits from your disk? (just change devNodeForDisk to fit in...) Aug 17, 2012 at 15:41
  • @Sampo I think the flash drive is already broken. It can't read anything. Never been try Linux.
    – Erico Yan
    Aug 21, 2012 at 15:40
  • What you mean by "It can't read anything"? What have you tried? If Windows can't read it does not mean anything. And what about capacity, does Windows get consistent information about its capacity? Aug 21, 2012 at 16:48
  • For Linux part, there is lot of live cd/live usb distributions available which means that you don't need to install it to your HDD. Aug 21, 2012 at 16:55
  • 3
    Possible duplicate of What can I do if my USB flash drive is write-protected or read-only?
    – bwDraco
    Sep 17, 2016 at 5:12

9 Answers 9

9

You can try TestDisk (free, cross-platform, and open source) - it works on almost all drives on a system, regardless of whether or not the drive is internal or external. You can use TestDisk to rewrite any partition tables found on the drive - it can even find corrupted or missing partitions and then repair the partition table.

Alternatively, you can also use TestDisk to simply recover the files without repairing the partition table (if you just want to format and start from scratch). TestDisk can also overwrite/recover the MBR or boot sector if that's corrupted as well. I've had success using it to copy files off of corrupted partitons/drives.

3
  • I've already used TestDisk but it didn't workout. Same problem persists.
    – Erico Yan
    May 10, 2012 at 22:30
  • I've successfully used this to recover data from a 300GB USB harddrive. I did not manage to repair the partition table. It's still RAW although I set it to NTFS and a P or * partition several times. It always talks about rebooting, which does not make sense with a USB hdd I think. I've tried unplugging, safely removing in Win7 and even rebooting and turning off the computer, unplugging, booting and plugging back in, all to no avail. Still, we got the data back, so I think this is a great tool. Thanks a lot!
    – simbabque
    May 13, 2013 at 17:38
  • The TestDisk download link is broken Sep 10, 2019 at 4:31
2

I encountered the same issue just a few minutes ago. My USB flash drive was working fine at home then suddenly it was not recognized by any computers in the office. When attempting to access it, I always get the prompt to reformat.

To resolve the issue, I click "Yes" on the do you want to format prompt then closed the next window (I did not click on the START button to start the format process). Received an error stating that Windows cannot format the drive. Unplugged the drive from the USB port then plugged it again.

1

diskpart is, in my experience, unreliable sometimes. It would show some filesystems as RAW when actually they are just not recognized, either because diskpart cannot do it, or because it didn't work, for some reason.

I suggets trying GParted. You can get it as a live-CD (or live-USB) and see if it detects your USB filesystem better.

6
  • I will try this one. What should I use? It said that "WARNING! Makeboot.bat must be run from your USB flash drive." Any suggestion for this one? I don't have any idea about this batchfile? pls. need to fix my flash drive asap.
    – Erico Yan
    May 10, 2012 at 22:34
  • When you're setting up the live USB with the command line, you must be sure to be under your USB drive. Don't run makeboot on your system drive (C: ?) as it would make it unusable. Please note that this is the installation of GParted, which must take place on a separate disk than the one you are going to recover. May 11, 2012 at 6:37
  • I would like to ask something. Should I use a Virtual Machine for this one? or Should I use the BIOS? I already burn it bootable in CD. I hope this one works. Thank you so much for your feedback. I appreciated it.
    – Erico Yan
    May 13, 2012 at 14:50
  • I've already tried Gparted. I tried to used VMware workstation and also boot it in BIOS. Unfortunately, the same problem persists. Is it considered broken? The media is write protected. Is there any way we can fix this problem? So that in the long run, everyone can benefit something about this certain problem about the corrupted USB.
    – Erico Yan
    May 14, 2012 at 4:20
  • I would have said "when you have created a GParted LiveCD or LiveUSB, boot on it by selecting the boot device in BIOS (no VM!), and see what it can find in there." I assume it's what you've tried. When you say "the same problem persists", do you mean GParted sees it as RAW ? May 14, 2012 at 6:22
1

On Windows, I just tried ZAR (Zero Assumption Recovery) with its free "Image Recovery" function.

All my files have been recovered, even those deleted.

It help very much but some files can't be recovered That's what I discovered when i use demo version

0
0

GParted is one of my favorites....Found as an iso itseld, also part of the Parted Magic cd...

Disk Genius has also worked for me in the past for somewhat corrypt partion tables (fixed disks and usb flash drives).

4
  • I've tried disk genius but it cannot fix the corrupted USB. It said that the media is write protected. @DeemV
    – Erico Yan
    May 10, 2012 at 22:50
  • try to obtain Hiren'S Boot CD...it contains a list of tools perfect for situations like this...one of those tools will surely do the job.
    – DeemV
    May 12, 2012 at 9:00
  • I asked some people esp. IT technicians that it is already broken. I hope this one works.
    – Erico Yan
    May 13, 2012 at 14:22
  • The same problem @DeemV. The device media is write protected.
    – Erico Yan
    May 13, 2012 at 14:24
0

Most probably your USB device's memory unit is broken or there is problem in connection between flash memory controller IC and flash memory IC.

Operating system recognizes it as USB memory unit. This means that USB interface IC (memory controller) is working. However, operating system does not get any information about USB device's memory (capacity, partitions, any bits from flash memory).

One thing you could do is taking apart you USB device and try to examine if there is any burn marks (usually small grey or white dots/circles in IC surface). Also look for bad copper wires and for bad connections between wires and components.

If memory IC (usually biggest IC in board) in board looks okay you could try to resolder it or change it to another board. Look from google about soldering surface mounted ICs if you want to try it.

0

Try chkdsk (from within a Windows system).

Open a command prompt with administrative rights and type: chkdsk p:\ /F where p stands for the according volume letter. /F stands for the option to repair found errors.

1
  • 2
    chkdsk does not work on RAW file format
    – Bmize729
    May 23, 2014 at 2:31
0

Disk Drill did a decent job for me of detecting and extracting "recoverable" files. There is a limit of 500MB in the free version, but you can easily prune unwanted files to get within their limit [or upgrade to Pro - it is a good idea to support developers who create tools you find useful].

As a general rule, avoid using removable drives for business or personally critical files. And take regular backups of important files. It is time-consuming to do, but can usually be automated or started while you do something else. And when the inevitable disk failure does happen, those backups can turn into a lifesaver.

-2

I have the same problems and have tried so many methods but finally this one is working. Use this software to low-level format the USB and it will remove write-protected.

It's called, "HDD LLF Low Level Format Tool", and the main website is here.

Screenshot

ss of tool

It's free for personal use (speed is capped at 180 GB per hour which is 50 MB/s).

2
  • 1
    Hopefully this isn't an advertisement!
    – slm
    Apr 26, 2013 at 16:52
  • 2
    That solution works in case the OP wants to erase all the drive and don't mind the files, but he needs the files to be recovered. Sep 27, 2016 at 12:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.