4

I can't install JDK on my Windows 7 64bit system. I downloaded the latest version (jdk-7u4-Windows-x64.exe) from Oracle and ran it. A warning appeared, because it's a download. I commited to continue. Nothing happened. Thus, I tried again (several times). Without success.

Therefore, I downloaded the installer again and tried as well the 32bit version. But no effect.

Hence, I monitored the hard disk with "Disk Pule":

Created, modified and deleted at the end:

C:\Users\USERNAME\jdk1.7.0_04_combo\java_jdk.exe

2 folders were created in:

C:\Windows\Temp\

And after all, this was modified:

C:\Windows\Prefetch\JDK-7U4-Windows-X64.EXE-341334B2.pf

I am at my wit's end. Any ideas?

Edit: Same problem on another PC with Windows 7 64bit.

5 Answers 5

1

Try with the zipped binaries. Unpack, point your apps to it, done.

EDIT: Check this thread https://stackoverflow.com/questions/1619662/where-can-i-get-the-latest-jre-jdk-as-a-zip-file-i-mean-no-exe-installer

2
  • Where can I get them?
    – MegaMuetzenMike
    May 9, 2012 at 21:39
  • Edited the answer.
    – Alfabravo
    May 9, 2012 at 22:39
1

I had similar symptoms. I don't know if we have the exact same problem, but I only had JRE 6u32 and the JDK I was trying to install was 7u4. I downloaded JDK 6u32 and it installed perfectly.

Might just be a version mis-match. HTH

1

I had the same issue, nothing happened after i double clicked jdk installer. My problem had been that my window's builtin administrator has russian letters in name => these letters were in the home folder name, when i created new admin user with only english letters and delete old, all installed, Check your windows user for utf-8 letters, eg: ®, ã, ë or any other non english letters.

1
  • This shows what a quality of shit is Java! How do they not test on a non-english Windows? How do they not display an error if there is any problem. That is really a SHAME!
    – Elmue
    Dec 24, 2020 at 20:27
0

It happens recently to me that neither JDK11 nor JDK15 (64 bit) will install on my Windows 7 (64 bit). The installer (exe) simply crashes. This is very bad quality software!

However, the older installer for JDK 8 (exe) can be installed normally.

I have the impression that this installer requires Windows 10 and Oracle programmed that so sloppy that it does not check the OS. If they require Windows 10 they should display an error saying so. Also the homepage says nothing about OS requirements.

The solution was to download the JDK package as ZIP instead of Exe.

The Java JDK 11 runs on Windows 7! It is just the installer which is a peace of sh...ame.

-1

Solution 1: Upgraded your OS and the try.

OR

Solution 2: Right click on JDK installer and select Unblock. And then click OK.

1
  • Could you expand your "solution 2"? Your first solution is the nuclear not really acceptable answer.
    – Burgi
    Apr 11, 2016 at 23:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.