I'm running Google Chrome. When I do anything that'll save a file to my local filesystem - right-click and "Save As", click a download link, save an image - nothing happens for a good 20-30 seconds, and then suddenly the operation proceeds as normal.

The browser remains responsive whilst this is going on - I can navigate to other pages and so on - but the delay is infuriating. Especially since it often looks like nothing's happening, so I'll hit the download link again - and again - and then suddenly end up downloading four copies of the same file.

Any ideas?

  • similar happens to me when using a file upload element to select a file May 10, 2012 at 11:31
  • 1
    I wonder if it is Chrome's "safe browsing technology" that is scanning the url and download? You might disable this feature temporarily to see if it makes a difference..superuser.com/questions/387724/…
    – Moab
    May 10, 2012 at 15:08
  • There is more info in this recently linked duplicate: superuser.com/questions/586878/…
    – Zero3
    Jan 26, 2014 at 8:16
  • Chrome is actually downloading the file before you press the save button in the Windows explorer dialog. You can see that it downloads some files almost instantly, and some files are half downloaded when you click the save button.
    – redbeam_
    May 31, 2015 at 8:05
  • 2
    @redbeam -- only true if pre-fetching is enabled (not the default til 44 btw) May 31, 2015 at 13:41

13 Answers 13


The same happens on my computer. I have the default download directory set up to save to an external USB hard drive.

The drive always has to spin up before the file is saved. You can hear and see this process very clearly.

  • 20-30 seconds to spin up a drive? O_o May 10, 2012 at 13:09
  • 1
    @grawity: The drive goes into powersafe mode once it isn't used for a while. Once I access it, it has to completely power up again. It's quite annoying :P May 10, 2012 at 13:27
  • 2
    Just had this happen again (three years after the original post) - Googled it and found my own question. Last time around, it persisted until I reinstalled Windows a few months later... but THIS time, it was because the default Downloads folder was on a drive that was spinning down to save power when it wasn't being used. So have a much-belated accepted answer :) Jun 1, 2015 at 12:17

1. Disable hyperlink auditing

(Click images to enlarge)

2. & 3. Clear your cache as this CAN actually slow down initial download connecting - since it looks for previous metadata FIRST.

(In Settings -> Clear browsing data... -> select any non-defaults as suits you.)



4. Check for bad/old/suspicious certificates (malware, etc. can be injected via certificates being implanted and sites being redirected ---cert pinning only helps if these are not system trust certs (for list of valid/common ones your search engine of choice should return a healthy list)

(In Settings -> Manage Certificates -- you must click Show advanced settings first to see it)


  • 2
    SU's purpose is to build a knowledgebase; people contribute Q's in exchange for getting an answer, themselves. The OP's experience is irrelevant; you aren't answering them, but the novices who will come looking for a solution to a similar problem. You've put in a lot of effort--126 A's already. But most got 0 or negative votes. That's mainly because many are little more than comments that assume people will understand the implementation. BTW, +1 for what you did with this one.
    – fixer1234
    May 31, 2015 at 17:13
  • 1
    I've been with this annoying issue for a while now. I am actually returning to Firefox as I can stand resetting my Chrome completely every couple of months as the only fix till now. I've cleared the cache and histoy downloads as per your suggestions and think that (on its own) did the trick, so it's likely something related with size and slowness of the cache accessing certain data. Thanks.
    – luison
    Jul 8, 2016 at 8:40
  • 1
    Thank you very much. This has fixed the issue here for me (in Chromium v66).
    – tomasz86
    Apr 28, 2018 at 7:19

I know this isn't technically an 'answer' per se. However, it drives me nuts too! What I have found is that Chrome is checking for updates, which causes the delay.

Next time it happens, click the customise icon in the top right corner, click 'About Google Chrome' and just below your existing version, you will see it checking for updates. Once that process has finished, the downloads begin as normal.

It usually only happens to me once per 'session', but it's still infuriating and I don't know how to prevent it from occurring.

  • 3
    I would disagree here, I have the same issue, regardless of whether Chrome is updating not.
    – Kev
    Jan 25, 2014 at 23:42
  • Not sure if coincidence or not, but it was updating for me at the same time. Jul 17, 2014 at 12:20
  • This is a valid answer. I had the Issue the original poster had. Clicking a download link would result in a delay of up to 10 seconds before the file download bar and progress would appear. I saw this answer and glanced at Chrome's menu button and sure enough, it wanted to update. After the update, files now downloaded normally without any delay.
    – Mister Tea
    Aug 23, 2017 at 20:02

I ran into this issue a few months ago, on a freshly built computer. The slowdown began after 3 months of use. I am actively researching this problem.

Here's what I've been able to find out so far:

  1. I installed Chromium and Google Chrome Canary to test them for the problem. Google Chrome Version 43.0.2357.81 m (64-bit), Google Chrome Canary Version 45.0.2417.0 canary (64-bit), and Chromium Version 45.0.2418.0 (64-bit) all have identical behaviours in terms of Windows Explorer being slow for myself. All of these browsers having the same issue is a good pointer for the origin of the problem, as Google Chrome is developed from Chromium. This may also suggest a fundamental (global) software bug with Windows Explorer.

  2. Other web browsers, such as Mozilla Firefox and Internet Explorer 11, do not show any of these slow behaviours. This suggests that the problem is mostly related to Chrome/Chromium, and that it is not a filesystem problem.

  3. Disabling "Phishing & Malware Protection" is a suggested solution, but it has not worked for me. Running CCleaner is also a suggested solution, but it has not worked for me either.

I will update this as I find out more. I hope it helps someone.


Anything to do with the filesystem, I'd get a copy of Process Monitor.


Then see what's happening on the filesystem, Filtering on your path. See if Chrome is waiting or another process.


Do you face the same problem when you are using another browser such as Mozilla Firefox or Internet Explorer? If so, then the problem most likely has to do with Windows.

If you have recently install any new applications, use Windows' System Restore to rollback the changes.

Another common problem on Windows Vista or Windows 7 is when performance is much worse after installation of updates - that you may not be aware off. Usually this problem goes away after a few reboots.


I had the same problem in windows 7 x64, the solution was install chrome 64 bits...


I actually was having this same issue. And just found a fix for my windows 10 system.

The folder I'm saving to had 1,418 items in it. Something in windows is stalling due to the number of files. I moved ALL files (even hidden files) files to another folder and BOOM instant saving again.


In my case the slow (7 seconds?) save dialog in Chrome 87 disappeared when i disabled power saving on my WiFi stick. In Windows 10: Device Manager, Network, WiFi dongle, Properties, Power Management.


Depending on what the issue is, this may help. If your issue is saving to secondary hard drive that has to spin up again, I have found that opening file explorer and going to my downloads folder, which is on my hard drive, helps. Although I am not sure if you need to go to a location on that disk. Keep it open until you are done saving things.

This may be a bodge solution. I only have this issue when saving videos from a video player.


i had this issue as well, what happened was I had a map to another PC that goes to sleep from time to time and thus the network share path is broken in Windows "Quick Access". But, it'll waste time stalling out trying to find it until it gives up and the Save as comes up. Just had to unpin the Quick Access path.


The easiest and fastest solution is:

Press Windows key and search for "cmd" Right click on "cmd" and select "run AS Administrator" Enter "netsh" to Start the netshell Enter "winsock reset" to reset

You will be prompted for a reboot

After reboot you will experience a faster system and no more problems with right click save AS...



I removed "Page Cache Archiver" addon and now everything works fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .