1

I am trying to edit hosts file on my computer.

I click start -> find notepad shortcut -> run it as administrator (window on dimmed background appears) -> i press yes -> find hosts file -> edit it -> press file-save

But, it still opens the dialog where i want to save the "new" file. If i press save, a new .txt file is created.

Any suggestions?

(I am the only user AND administrator on my computer)

Thanks

  • What happens if you select the existing hosts file in the "Save" dialogue? Notepad should ask you if you want to overwrite the file, so click Yes to that prompt. Does that work? – Indrek May 13 '12 at 12:22
  • maybe the file is read only? – leonigmig May 13 '12 at 12:23
  • @leonigmig i did, like the Indrek said and the dialog window said that the file is READ ONLY, yes. What should i do now? – user6613 May 13 '12 at 12:31
  • before you save, right click on the file and go to properties, then un-check read only. – leonigmig May 13 '12 at 12:35
  • i made it an answer so you can give me some points :) – leonigmig May 13 '12 at 12:44
0

before you save, right click on the file and go to properties, then un-check read only.

  • i can't uncheck it – stiv Aug 9 '18 at 13:18
2

The way you do it, it should work. Probably you have installed a security tool (antivirus or something else) that prevents the file from being modified. You can check also the permissions manually (properties security dialog.) Maybe the permissions were changed through such a tool.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.