My mspaint that comes with windows 7 (64-bit) worked at some point, but a while back it suddenly starting posting an error when I try to use it.

mspaint error

The version of this file is not compatible with the version of Windows you're running. Check your computer's system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher.

If I try to run it as administrator by right clicking the mspaint.exe in the system32 folder, I get the following error:

mspaint admin error

Windows cannot find 'C:\Windows\System32\mspaint.exe'. Make sure you typed the name correctly, and then try again.

I don't know what made this start, and at start it wasn't a big problem but it has gotten kind of irritating over time.

I looked for a way to re-install it but a fast search on the internet shows it is a standard part of windows and it can not be uninstalled. How can i fix this with out having to re-install windows?

  • Have you tried running it with administrator permissions or in compatibility mode? – Simon Verbeke May 13 '12 at 15:26
  • @SimonVerbeke: You can't run an application that is part of Windows (including Paint) in compatibility mode. – bwDraco May 13 '12 at 16:01

Try typing sfc /scannow into an elevated command prompt and wait for it check the system files.

I am not sure if it checks built-in applications as well, but it's worth a try.

  • I got a "Windows Resource Protection found corrupt files but was unable to fix some of them." and when I look in the log i find a couple of entries with mspaint one of them being 2012-05-13 17:15:48, Info CSI 0000039c [SR] Could not reproject corrupted file [ml:520{260},l:46{23}]"\??\C:\Windows\System32"[l:22{11}]"mspaint.exe"; source file in store is also corrupted – Blem May 13 '12 at 16:22
  • @Blem: I would check your disk health with a SMART monitoring tool as soon as possible. It sounds like your drive may be about to fail. – paradroid May 13 '12 at 19:45
  • only thing that fails is spin up time on one of my storage drives, the drive with windows on passes Quick Test, will run a full test tomorrow but it looks ok. – Blem May 13 '12 at 20:56
  • An Extended Test showed nothing wrong with the drive that windows is on. – Blem May 14 '12 at 6:49

You could try to replace it. I have uploaded a working copy of mine (64bit) to dropbox. This link should allow you to download it. Then place it in your system32 folder. This will prompt you to replace your current copy.

After replacing, try to run it again.

  • It is protected by TrustedInstaller, my other users (SYSTEM, Administrators and Users) only have Read & Execute permission. Trying to run your uploaded file just gives me an error saying "Unable to create a new document". – Blem May 13 '12 at 16:30
  • Didn't know this would be the case. If you really want to try this method, you could of course change permissions for the system32 folder. (this might include taking ownership of the folder) – Simon Verbeke May 13 '12 at 16:41
  • 2
    @Blem Try booting into Safe Mode, that should allow you to replace the file. – Indrek May 13 '12 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.