I installed APR(Apache Portable Runtime) by following commands:

wget http://apache.mirrors.pair.com//apr/apr-1.4.6.tar.bz2
./configure --prefix=/usr/local/apr
make install

Now when I ./confgure httpd, it fails with following message.

checking for APR version 1.3.0 or later... no
configure: error: APR version 1.3.0 or later is required

Can someone please help me?

Here is the complete log:


 checking for chosen layout... Apache
 checking for working mkdir -p... yes
 checking for grep that handles long lines and -e... /bin/grep
 checking for egrep... /bin/grep -E
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu

Configuring Apache Portable Runtime library ...

checking for APR... yes
setting CC to "gcc"
setting CPP to "gcc -E"
setting CFLAGS to " -g -O2 -pthread"
setting LDFLAGS to " "

Configuring Apache Portable Runtime Utility library...

 checking for APR-util... yes
 checking for gcc... gcc
 checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... gcc -E
checking for gcc option to accept ISO C99... -std=gnu99
checking for pcre-config... /usr/bin/pcre-config
configure: Using external PCRE library from /usr/bin/pcre-config
setting PCRE_INCLUDES to ""
setting PCRE_LIBS to "-lpcre"

Configuring Apache httpd ...

 setting INCLUDES to "-I."
 adding "-I$(top_srcdir)/os/$(OS_DIR)" to INCLUDES
 adding "-I$(top_srcdir)/include" to INCLUDES
 adding "-I/usr/cisco/packages/httpd/httpd-2.2.6/include" to INCLUDES

 Applying OS-specific hints for httpd ...

checking for rm... /bin/rm
checking for pkg-config... /usr/bin/pkg-config
checking for rsync... /usr/cisco/bin/rsync
checking for gawk... gawk
checking whether ln -s works... yes
checking for ranlib... ranlib
checking for lynx... no
checking for links... links
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking minix/config.h usability... no
checking minix/config.h presence... no
checking for minix/config.h... no
checking whether it is safe to define __EXTENSIONS__... yes
checking for library containing strerror... none required
checking for APR version 1.3.0 or later... no
configure: error: APR version 1.3.0 or later is required

My guess is, it's finding an older system APR-util, and not the one you just installed.

I'd check the configure.log to see which APR it used.


You should provide the APR util option along with APR as below. This worked for me using Apache version 2.4.x and APR version 1.4.x:

./configure –with-apr=/usr/local/apr/ –with-apr-util=/usr/local/apr-util/

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.