I encounter some issues configuring audio with ALSA on my Seagate Dockstar on which I plugged a little USB audio card.

I'm able to play music with MOC but I'm stuck with a volume way to high.

Whatever I tried, the gain of the PCM control is stuck above +10dB even when the sliders of alsamixer are at 0%, and the sound is really too loud unless muted (speakers or headphones).

When I increase the volume, the gain grows further and the resulting volume increases further too, so the control of the volume works, but the problem is that it begins at +10dB instead of -48dB.

This is the output of amixer command when I lower the volume at the minimum without muting:

root@host:~# amixer
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch pswitch-joined penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 13568
  Front Left: Playback 1 [0%] [10.00dB] [on]
  Front Right: Playback 0 [0%] [10.00dB] [on]
Simple mixer control 'Mic',0
  Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
  Capture channels: Mono
  Limits: Capture 0 - 6096
  Mono: Capture 0 [0%] [0.00dB] [on]

Notice the [10.00dB] even if I'm at 0% volume.

I followed this guide to configure it all.

I remember that I followed this before (more than one year ago), and that it worked back then, but I can't remember if I had to tweak something specific or not at that time.

I don't want to install Pulseaudio if possible, as I really think it is overkill for just the sake of playing a sound file (for those who don't know what the Dockstar is, it is a dock for hard drives which features 4 USB connectors + 1 Ethernet Gigabit, with a "motherboard" based on an Kirkwood ARM architecture).

I just did a base-install of Debian Squeeze and this is console only. I really want to avoid to install all the x11 dependencies of Pulseaudio.

Moreover I know that it worked in the past without the need to install more than ALSA.

TLDR: How can I alter the base gain of the PCM channel in ALSA?

Here is the Output of an information script which shows all my current config.

NB: I already tried to use max_dB and min_dB in /etc/asound.conf as proposed here, without success.

  • have you solved this issue?
    – scjorge
    May 11, 2016 at 4:18
  • No, would still welcome an idea on how to solve this.
    – Zertrin
    May 12, 2016 at 14:21


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.