I have Lenovo Ideapd Y510 laptop with windows 7 and its keyboard has suddenly stoped normal working. Its few keys are working and other are not as they should. As you can see in image the keyboard has a function key of left bottom corner and you all knows on pressing fuction key the secondary functions of keys gets activated. The keyboard is behaving like as if I have pressed FN key, I mean when I press left arrow key then instead of moving cursor to left the volume start dicreasing because left arrow key also works to reduce volume on pressing FN key then left arrow key. When I press U key then insted of typing U it types 4 because U key behaves as number key 4 on pressing FN key.

What I mean to say here is that keyboard is functioning like I have pressed FN key. All keys are doing their secondy tasks not primary, the keys which do not have secondary option are working fine.

Is it a normal issue that could be fixed at home or should I take it to a laptop service center?

enter image description here


I think it is a short somewhere, probably caused by some debris, dust or liquid. I've had something similar happen with ThinkPad keyboards.

Try using a vacuum cleaner, with the nozzle over the keys, and particularly on the edges of the keyboard (as you seem to have removed it anyway). I'd use a clean vacuum cleaner bag, in case you need to recover any keycaps that get sucked up.

If that fails you could try a can of compressed air. Then you can try drying it in a warm (but not hot or humid) area, in case it is liquid shorting it out.

If none of that works you may need to get a replacement keyboard from eBay or similar.


Is there a FN Lock key on your keyboard?

It sounds as if you have pressed that. I can't see from the image but you should be able to have a look and simply press this again. Should return the keyboard to normal working order.


Looks like you either have it sticked with Fn-lock/Windows sticky-keys or it's a hardware failure: the Fn button is simply stuck. In the latter case, you might want to examine if there's anything that is holding the key.


I am having a similar problem with a Yfive 10.The number keys five and seven do not work. in addition to underscore and plus sign. I have tried 3 keyboards, all have same exact problem. I believe in this case the system board may have to be replaced.

  • 1
    Are you saying you've replaced the keyboard in the laptop three times? – Tanner Faulkner Oct 24 '12 at 20:03
  • In my case fault was in keyboard. I bought new laptop keyboard for my Y510 from eBay and new replacement keyboard worked fine for me. – Sandy Oct 25 '12 at 5:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.