ASRock Z68 Extreme 4 MB

Core i7-2600K @ 3.4

Installed memory: 8.00 GB (1.92 GB usable from Windows) 2x 4GB mem sticks (2x2GB)

Windows 7 - 32 bit

A week ago, I had (3.8 GB usable), which I expected due to the 32 bit install.

I moved apartments, so the PC likely suffered some shock or impact, and now it is showing (1.92 GB usable).

Things I have checked:

  • Bios shows 8GB, and has memory mapping active
  • Windows msconfig->boot->advanced->max memory is unchecked
  • Reseated and swapped both memory sticks
  • Reset bios

What should I try to troubleshoot next, given that a moving shock might be the cause?

  • Could also check to see how much system memory is designated for onboard video in the BIOS. – Phillip R. May 18 '12 at 13:52

First - I would try Memtest86 and see if it detects all the RAM and if there are any defects / errors.

If it fails - I'm not sure if you're talking about a jarring shock or electrical shock, but it may also be a defect, if the RAM is still under warranty - see if you can get it RMA'd.

If it doesn't fail (which will be odd), I would update the BIOS.

If Windows is still reporting 1.8 - try booting an Linux live CD of some sorts and see how much RAM it detects. If it's showing up correctly, try re-installing Windows.


Check for hardware problems(Try booting with each memory stick plugged in one at a time). A bad memory stick would result in boot failure. Also check RAM using softwares as suggested by Dustin G.

If all sticks are fine, then,

Which graphics card do you have? OR do you use onboard graphics?

In case of onboard graphics, some of the RAM will get allocated to be used as GRAM and therefore is rendered useless as RAM. Now, how much RAM to dedicate to graphics can be controlled from BIOS settings. Check this setting (BIOS might have assigned huge RAM to gfx bcoz your system has 8 gigs of RAM. But, it does not understand that x86 windows can use only 4 gigs of it.)

If this doesn't work out, check RAM with some Linux live distro. If it shows everything OKAY, then repair/reinstall windows.


Turn off memory remapping in the BIOS. A 32-bit OS without PAE has no way to access remapped memory.


Check how much memory windows sees with memory remap switched off, windows should see above 3GB then, but around 2GB with memory remap ON. It seems that changing that options could be the reason of the difference you see.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy