yesterday the power went out for a second. I then noticed that my router (D-Link DGL-4300) had stopped working. It didn't power on at all.

Today I borrowed my friends power adapter because he has the same router model as I have, and now the router works, so it was the power adapter that broke.

Now however, I don't seem to get any internet from the router. I can perfectly access the network and all the other computers and stuff, but none of the connected machines get any internet. My computer and my NAS is connected with cables, and my iPhone is connected wirelessly, and none of them get any internet, but they can all access the network.

In the router page ( I can see that the router gets access to the internet. I can see my external IP and I don't see any errors.

So what could be wrong? Is my router broken? All the machines can access the network but none of them get any internet, even though the router can access it. I've tried restarting the router as well as my computer, and I've tried renewing the IP addresses but nothing seem to help.


  • 2
    FWIW, when I lose power or whatever, I need to restart the router and let it finish starting up before I turn the cable modem back on. If I do it the other way, or simultaneously, it doesn't work.
    – ale
    Sep 17, 2009 at 12:48
  • I tried restarting them in the order you said and it actually works! If you re-write this comment as an answer I could mark your answer as the accepted one.
    – sippa
    Sep 17, 2009 at 14:35

1 Answer 1


First, hook up a machine directly to the modem. Does it get internet access? If yes, then the problem is the DHCP server in your router. If it doesn't, then maybe the power surge hurt your modem.

That test will tell you for sure if your router really does have internet access, because your computer will be hooked up the same way the router is, right to the modem, except that you can test your internet connection on it now.

Look up the D-Link support to see what your settings should be. Also, you can do a hard reset that will reset the router to factory defaults and start over.

It really just sounds like your DHCP settings are messed up and not that the router is bad. If you do a full reset and start the router settings over and still have the same issue, then it may be the router. Try this and let us know.

  • I have tried connecting the computer right into the modem and it works, so I will try resetting the router in an hour when I get home.
    – sippa
    Sep 17, 2009 at 13:20
  • Before i resetted the settings I wanted to try Al Everetts suggestion and it actually works, so now I don't have to reset it. But thanks for your help anyway!
    – sippa
    Sep 17, 2009 at 14:40
  • Great. Glad you got it working.
    – th3dude
    Sep 17, 2009 at 14:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .