I had a problem with my USB drive. When i plug it in windows 7, what happens is when I click on USB the message "Please insert a disk into drive X:".

The drive properties show:

Type: Removable Disk

File system: Unknown

Used space 0 bytes

Free space 0 bytes

Capacity 0 bytes

I usually remove it without 'ejecting' or 'safely removing' it, can this be related? How can I solve this problem?

  • sorry. in Ubuntu 10.4 – Perdana Putra May 18 '12 at 23:30
  • you can edit your questions; there's no need to make corrections in the comments. – Renan May 18 '12 at 23:33
  • sorry, i'm newbie. i'm Confused, how do I save my data – Perdana Putra May 18 '12 at 23:50
  • Lead to possible duplicates provided here – bummi Feb 18 '16 at 14:06

Try this, from the Symbianize forum:

So, with nothing to lose, I pasted http://u3.sandisk.com/download/lp_installer.asp?custom= into Internet Explorer, thinking that it would at least get me some new files that might allow me to reformat the drive. I followed a few prompts and lo, the U3 Launchpad Installer software launched and restored the drive to its factory settings of 2 GB capacity formatted as FAT. It even replaced the original U3 files, making it truly good-as-new.

I’m astonished that this information isn’t more widely available, particularly on the SanDisk support site and forums, as this 0 capacity problem seems to affect a good number of drives and there are many threads where this issue remains unresolved.

Note that the page at http://u3.sandisk.com/download/lp_installer.asp?custom= requires you to install an ActiveX component, so you must use Internet Explorer.

Otherwise, you can download the latest version of the U3 Launchpad Installer executable from the Sandisk KB.

Of course, if you’re not using a SanDisk drive, it’s rather unlikely that this software will fix your drive, but maybe your device’s manufacturer has something similar. There are also a number of good ideas in the comments below, so definitely read through them for more options.

If you’re trying to restore the drive’s contents or recover files, the all of the methods described on this page will format (erase) the drive and are not for you. Good luck.

|improve this answer|||||
  • Here's your second warning. In the future, please attribute content properly, by adding quotes and a link to where you got the material from. – slhck Jun 5 '12 at 14:01
  • 1
    Doesn't work... only works for Sandisk drives. – dialex Oct 26 '13 at 11:34

Try Use Software; Apacer Repair v2.9.1.1 free trial of the utility from http://www.flashmemorytoolkit.com/ HP USB Disk Storage Format Tool v2.1.8 and, hwat happen if you plug it in ubuntu 10.4 again? it's same ?

|improve this answer|||||
  • 2
    that all the tools to format the USB? how i recover files? I Googled, many people were running into this problem where the drive starts reporting 0 bytes capacity and can not be formatted and I do not want to format my usb, I am afraid I can not get back the data – Perdana Putra May 18 '12 at 23:52

Try using the utilities PhotoRec and TestDisk. They're available for both Linux and Windows, and try to recover files and partitions, respectively.

|improve this answer|||||
  • photoRc, that's FREE ? ok, I will try it. Thank's Mr.Renan – Perdana Putra May 19 '12 at 0:00
  • Yes, it's free (and open-source, in fact). – Renan May 19 '12 at 0:01

I had 2 SanDisk USB one Cruzed Glide and one Cuzer, both showed on Windows 7 as removable disk, used space 0, free space 0, both had important files on them so I could not do anything down the line of formatting or turnning back to U3. What worked for me,, plugged into USB went into Device Manager, uninstalled device then removed from USB and plugged back in one at a time, allowed windows to scan and fix,, both worked after this. May not work for all but a goood alternative to try.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.