2

I tried installing iLife '11 even though I unknowingly already had it installed and I quit midway through the process. Now my iPhoto is screwed up and it has a white disabled picture for an icon.

When I click on it, it says

You can't open the application iPhoto because it may be damaged or incomplete.

How can I fix this? I'm pretty sure all my pictures are still saved somewhere but will everything still be in place once I fix my iPhoto?

2 Answers 2

0

First of all, don't worry. Your iPhoto picture data is stored in ~/Pictures/iPhoto Library. Thus, you can easily go ahead and make a backup of that whole folder just to be sure. If you ever find it deleted (which I highly doubt), just restore it as it was before.


Try to install it yet another time – but the installer run until it's finished.

If that doesn't work: "uninstall" the iPhoto.app by just deleting the file from /Applications and subsequently from your Trash. Also open a Terminal and paste the following:

sudo find /var/db/receipts -iname "*iphoto*" -delete

Then, try to install iPhoto once again.

9
  • Thanks! How can I reinstall it? Do I need a cd?
    – Seany242
    May 19, 2012 at 17:57
  • Well where did you install it from originally? It comes on the disc delivered with your Mac if it's Snow Leopard, for example.
    – slhck
    May 19, 2012 at 18:57
  • I ordered my mac online from apple and I don't think it came with a cd, it was just on the computer.
    – Seany242
    May 23, 2012 at 1:51
  • Well, you said "I tried installing iLife '11" so I guessed that you had an installer. The Mac App Store should have the iLife apps if the Mac runs OS X Lion. If you can't install them through the App Store, you might need to fix your Apple ID's purchases through telephone support or even an Apple Store.
    – slhck
    May 23, 2012 at 7:18
  • Yea sorry, that is a little misleading. My friend let me borrow it and that's when I screwed it up. If I try installing iLife '11 again, wouldn't it reinstall all of the apps I have in iLife? I just want iPhoto back. And the mac app store sells them for $15 with no recognition that I already owned the app so I don't want to waste $15.
    – Seany242
    May 23, 2012 at 22:40
1

For some reason my iPhoto suddenly reported "damaged" when it HAD been working for over a year.

The solution for me was to delete iPhoto (right-click or control-click , and select Move to Trash. Then I went to the Applications/Utilities folder and started up Terminal so that I could enter the

sudo find /var/db/receipts -iname "*iphoto*" -delete

command mentioned above. Finally, under the Apple menu (the Apple icon in the top-left corner of the screen), I opened the App Store, and in the App Store I selected Purchased, where it showed that I could install iPhoto.

Once that install was completed I could open iPhoto on my computer and I had full access to my entire photo collection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.