My WRT54G router usually works fine with my roommate's laptop and my laptop. However, whenever I connect my Sony Xperia Pro, the router drops all connections and restarts itself. Then I have to power cycle the router to be able to connect the laptops again.

Would anyone know why this is happening and how I can fix it?

  • What do you mean by "drops all connections"? Do you mean wireless clients no longer detect a wireless network? May 19 '12 at 5:27
  • @david-schwartz, I think so. It disconnects both laptops and the phone before restarting itself. Sorry, don't think I used the term right ;^_^
    – silversy
    May 20 '12 at 1:07
  • Do you have the latest firmware? If not, update. If so, try switching to Tomato or ddWRT. May 20 '12 at 4:45

A quick google search yielded an interesting hit. Although not exactly your issue, it does involve your router and some Sony hardware trying to connect wireless. It involves using a static setup on a PS3, while including the uPnP options that like to automatically do that setup. Check it out here.

There's also a thread on Sony's site that seems to be your issue, fairly exactly, though a different router. A firmware update on the router seemed to fix their issue. Check it out here.

One way or another, you're just having a conflict somewhere with settings between the two devices.

If you don't have a bunch of custom configuration on the router, I'd recommend first updating the firmware, and then restore to factory defaults. See if you have the issue with a clean slate.

  • Sorry to have taken so long (understatement of the year) getting back to this question. Firmware update on the phone fixed it. Thanks :)
    – silversy
    Apr 13 '13 at 2:09

my opinion about your issue is yours router is working fine but your laptop may be virus infected so kindly make sure first about your laptop, and observe status of sent receive bits i think may be your laptop sending more data due to virus. scan your computer with anti virus and then connect your laptop.


I had a similar issue. I resolved it by turning off Wirless N on the router. (Only Wireless G enabled now).

  • 1
    This sounds like a firmware bug to me.
    – bwDraco
    Nov 8 '12 at 20:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.