I got a IDE to SATA converter via Amazon, however when I hooked it all up the computer doesn't recognize the optical drive on windows 7 64bit. The only indication that the computer knows that it can see the optical drive is upon start-up the computer automatically goes straight into the BIOS. The device itself is getting power and so is the optical drive, I can vouch for the power supply and motherboard working correctly because they are new and I have been using them for the past week and this is a fresh install of windows 7 64bit

I have tried to fix the problem by:

  • going into device manager and checking for any extra drivers.

  • switching the settings on the drive itself from CS, SL, MA and then removing the jumper all together

  • looking on Google for an answer

Computer Specifications:

Windows 7 64Bit
AMD A8-3870 APU 3.0GHz
A75A-G55 MSI Motherboard
16GB 1866MHz RAM
nVidia GeForce GTX 560 Ti
C: 60GB vertex 2 SSD (50GB partitioned for Windows)
E: 2TB NTFS (Contains Program Files, Program Files(x86), User Files)

Any solutions are more than welcome... :)

  • I have connected the drive after windows has started and connected it in different orders that included connecting the power first then connecting the IDE to SATA adapter later both inside windows and when the computer starts. thanks for the reply though – n00b May 19 '12 at 19:41
  • Does your MB support SATA 2 or 3? Your converter may not work with SATA 3. – BJ292 May 19 '12 at 20:40
  • @user135048 post a link to the exact product you purchased on Amazon, please. – Bon Gart May 19 '12 at 20:47
  • The Motherboard supports SATA 3, the IDE to SATA adapter supports SATA 1 and 2 this is most likely the problem. This is the product : amazon.co.uk/gp/product/B003TNKREO/ref=oh_details_o01_s00_i00 – n00b May 19 '12 at 21:10

These ATA (you call it IDE) to SATA bridges usually only work one way. Either ATA host and SATA drive or vice versa. There are some bridges however that work both ways but those I know have separate SATA ports for SATA host and SATA drive. So make sure you got the correct bridge (and if it is a bidirectional one, you connected the right SATA port).

Also check correct orientation and position of the ATA connector. Some of these bridges can be connected with wrong orientation (rotated 180°) due to missing keying of pin 20 and the connectors shape. I have even seen connectors that could be inserted one pin off to the left/right. If possible, also test the bridge in another computer and/or with another drive, preferably a hard disk instead on an ATAPI device. The bridge might only support ATA and not ATAPI, but I guess this would be a rare situation, since I have never seen ATA/SATA bridge chips with such a limitation.

Setting your drive as device 0 (nearly always misleadingly called master) should work. Other modes might work too, but device 0/master will be the only reliable. You might want to check the used bridge chip's datasheet to be sure. The manual of the whole adapter (if there is any at all) might be inaccurate or misleading about this, as manufacturers sometimes only ship generic manuals and use different chips in their adapters depending on their market availability/price . The chip's datasheet will also be a trustworthy source on the usable direction (drive/host) of the bridge while a manufacturer with poor QA might just have put on a wrong label on the adapter.

  • "nearly always misleadingly called master" - Why is this "misleading"? Is it not standard nomenclature for the IDE interface? I haven't used drive select numbers (1/2/3/4) since Winchester drives with MFM (aka ST-506) or RLL intefaces. – sawdust May 19 '12 at 21:57
  • 1
    Master/slave suggests that the master has higher priority than the slave or even can control the slave. This is not the case. Both drives have the same priority and the host has control over both. Consequently the official specs do not use these common misnomers. I however do not know why it is still used nearly everywhere. It might have it's roots in the pre-ATA ages, when Western Digital invented their IDE interface on which the ATA standard is based, but even back then it was wrong. – Gurken Papst May 19 '12 at 22:47
  • 1
    Okay, it is now working i honestly don't know what i did to get it working. The closest thing i can think of might be linked to this: support.microsoft.com/kb/982116 Sorry i couldn't be anymore help to anyone else facing the same problem. – n00b May 20 '12 at 1:09

I had similar issues with an old IDE 40GB western digital hard that I used to store some documents as backup on my old PC, the jumpers are critical issue on hard drive, windows 7 64 bit won't boot or recognize the drive unless the sata cable connected to the bridge is removed and then plugged in after booting, then you have to launch DEVICE MANAGER, Then select look for hardware changes, the drive is recognized and a driver is installed by windows and shown under drives, why jumpers were critical, because either master or slave you have to use 2 jumpers the first jumper is identified by BIOS Either Master or Slave, the second jumper is to tell windows 7 to install special driver for the IDE Drive, too odd but glad it worked and was able to copy my documents to the sata drive.

  • 1
    As for the IDE/SATA Bridge, it work on mother boards that have IDE Socket to use a SATA drive, or plugged into an IDE Drive to use on SATA motherboard – Zakhari Aug 4 at 21:52

Had the same issue but solved it by moving the jumper on the ide CD/DVD player to "cable select". You might like to try.

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.