I have a very weird problem playing videos with Flash Player 11 and Firefox 12 in Windows 7. Seemingly randomly, after a few videos, the whole screen just goes black and the computer stops responding to any commands (as far as I can tell). The only way out is restarting the computer. The computer is fairly new and the problem has been always there.

Here's what I've tried/checked:

  • Firefox, Flash Player and Radeon driver are all up-to-date. As is everything else as far as I know.
  • The problem is definitely restricted to Flash Player. I use html5 for YouTube now and there have been no crashes there.
  • I've tried uninstalling and reinstalling the Flash Player. Also with the Flash Player uninstalling tool.
  • I've checked all the logs I've been able to find and found no references to the problem whatsoever. So I don't know exactly where to problem is.

Any ideas how to fix the problem?

  • Disable Hardware rendering in flash settings and try to load videos
    – HackToHell
    May 21, 2012 at 6:40
  • @HackToHell Coming back to an old question, disabling hardware rendering did fix the problem. Could you add that as an answer, so I can accept it "officially"? Although I'm still experiencing the problem randomly with Skype. I assume their ads are Flash based, but the normal Flash player settings are not available.
    – Carlos
    May 11, 2014 at 18:25

3 Answers 3


You could disable hardware rendering in your Flash Settings. Also you can try and use Pepper flash in Chrome instead of normal flash.


The latest version of Flash uses your GFX card to handle a lot of its processing, especially where video is concerned. Try updating your graphics driver to the latest version, also, does this happen in Chrome which comes with its own Flash binary I believe?

  • Drivers should be at the last version. I'm not sure about Chrome since I don't use it regularly and this problem occurs somewhat randomly, but I'll give it a try.
    – Carlos
    May 21, 2012 at 6:19
  • I've been testing with Chrome a lot now and this hasn't happened once. So it seems to be limited to Firefox.
    – Carlos
    May 24, 2012 at 20:15

I've recently had the same issue and i found that if I END THE MICROSOFT EDGE PROCESS in task manager it seems to work perfectly fine after. It worked for me. Hope this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.