I'm trying to fix a problem with my webcam in Wheezy, and I need some information about the drive with the command udevinfo. The problem is: where is this executable?

if I run sudo udevinfo the result is:

udevinfo: command not found

Any suggestion?


Debian web infrastructure supports searching packages by their contents.

The same result can be achieved using the apt-file tool.

Update: I was too confident you just don't know how to find a relevant package. In fact, this tool really was replaced by udevadm info as this post explains.

| improve this answer | |
  • I'm reading all... :) – Kyrol May 21 '12 at 9:18
  • Lnk is down (apt-file) :-( – Philippe Gachoud Aug 10 '18 at 18:55
  • 1
    @philippe-gachoud, here we go. – kostix Aug 12 '18 at 9:53

udevadm info is the new command. that replaces udevinfo

The arguments are same as udevinfo.

| improve this answer | |
udevadm info -a

Does what udevinfo -a -p used to do

| improve this answer | |

The answer above is incomplete: if you're like me, you're here because you have found yourself using some script (perhaps a "configure" script) that parses the output of udevinfo to ensure that udev is recent enough. In that case, the arguments to "udevadm info" and "udevinfo" might be the same, but the output isn't. For me, it was enough to replace the original line:

udev_ver=`udevinfo -V | awk '{ print $3 }'`


udev_ver=udevadm info -V | awk '{ print $1 }'

The script with this modification ran without errors, and I was able to get on with the rest of my life :).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.