Last week I installed SL6.2 on my tower using the LiveCD iso and unetbootin without issue. I was taking my time configuring it since it was my first real jump into linux. I ran into problems when I was attempting to replace the nouveau video drivers with the NVIDIA drivers. I was following the instructions here to do so, and had successfully gotten through step 3, however when I rebooted at the end of that step, it failed to boot due to a kernel panic.

After fighting with it for a while, I figured I would cut my losses and restart, so I attempted to boot from another flashdrive that was made from the same LiveCD as before and unetbootin, however I got a kernel panic consistently during the loading splash screen (it was at a different load point than the previous one).

I assumed that the corrupted install on the harddrive was conflicting with the USB boot somehow, so I successfully booted into gparted and removed all the partitions on the drive. Now, however, I am still getting a kernel panic from the USB boot, always at the same point, and using both the LiveCD and the miniLiveCD.

I am not worried about losing any data (obviously), but I am just too inexperienced at linux to even fully diagnose the problem. Right now I am capable of getting into the grub commands if that could help diagnose the problem, but any help at all to point me in the right direction would be greatly appreciated.

UPDATE: I have successfully booted Ubuntu 10.10 (just happened to have the iso sitting around) using unetbootin, so it seems to be Scientific Linux specific. Is it possible that something in the SL install is damaged by a bad sector on the flash drive I am using?


After the last update, I realized it had to be the flash drive. Apparently Scientific Linux requires FAT32 formatting, and the drives default formatting was FAT. Reformatting it and reinstalling SL6.2 onto the flashdrive solved the issue.

  • please accept this as the answer to your question so people know the question does not need to be answered any more. – Bram May 23 '12 at 18:27
  • sorry, it made me wait 14 hours before I could accept it. – Godric Seer May 24 '12 at 19:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.