Nope, my Windows XP's "c:[OS folder]\system32\drivers" folder doesn't have it. The technical guys removed it. And nope, automatic driver search doesn't work. Also, the machine doesn't have CD/DVD drive and I don't have the Windows XP CD. Where do I download that driver online?

  • Do you have the rights to use USB Flash Drive in the first place? Your technical guys definitely removed them for a reason (e.g. DLP, compliance purposes, etc). – fooyoong May 22 '12 at 4:08
  • Go to manufacturer site amd download them. – avirk May 22 '12 at 4:22
  • @avirk nope, these days manufacturers don't include drivers for very simple things such as USB flash drive. Windows provides it. It's just the technical guys removed it from the drive. – supertonsky May 22 '12 at 17:18
  • @fooyoong nope, but i have access to registry editor and did the necessary configuration to enable USB. The only problem is the missing driver. They've removed it from the drive so enabling it won't make it work. – supertonsky May 22 '12 at 17:34

Run the System File Checker

Open an elevated command prompt and enter this command

sfc /scannow

hit the enter key, scan will run and replace any missing or corrupted windows system files and drivers. This should replace the usb drivers that are included in Windows 7.

EDIT: For XP you do not need to open an elevated command prompt, just open cmd and run the same command, it will however ask for your Windows XP install cd.

  • This seems very dangerous to run on a coperate machine. – Ramhound May 22 '12 at 16:13
  • Safe as it gets.... – Moab May 22 '12 at 16:25
  • I'll try this thing tomorrow but I really doubt this as the driver files have been removed from the drive. And where is this sfc command going to get the files from to replace the missing files in the first place? Most likely it would ask for the Windows CD or something for which I cannot provide. I believe all I need is a download link to driver files for generic USB flash drive. Thanks though. – supertonsky May 22 '12 at 17:22
  • Windows stores backup copies or all system files. Vista and W7 no longer ask for the installation dvd, it gets them from the hard drive, and unlike XP it will always have the latest versions. – Moab May 22 '12 at 19:02
  • @Moab My bad. This is an honest horrible mistake, I thought my machine is on Windows 7 as I usually use Windows 7 but the machine is actually running on Windows XP. I only realized that when it asked me to insert the Windows XP CD. I guess I'll accept this as an answer for Windows 7 and re-post this exact question for Windows XP. See you there. Thanks by the way. – supertonsky May 23 '12 at 6:33

download Driver Identifier and let that tool find out the hardware id of the USB-device you have in your machine .. it will also yield multiple driver-download-urls directly into your face.

enter image description here

  • Let me try this thing tomorrow and see. Thanks akira – supertonsky May 22 '12 at 17:24
  • Tried this site, it's giving me broken links to the drivers. – supertonsky May 23 '12 at 6:29
  • it lists lots of links, some of them might be broken. what is the device id of the bugging USB-device? – akira May 23 '12 at 6:52
  • I tried at least two links and gave up. Device Info: USB Flash Drive Hardware ID USB\VID_090C&PID_1000&REV_1100 USB\VID_090C&PID_1000 <---- Your Driver Compatible ID: USB\CLASS_08&SUBCLASS_06&PROT_50 USB\CLASS_08&SUBCLASS_06 USB\CLASS_08 – supertonsky May 23 '12 at 6:57
  • so it's a cardreader? that link here worked driveridentifier.com/scan/… – akira May 23 '12 at 8:48

There are more than a dozen generic USBxxxx.sys drivers in that folder (hidden) C:\Windows\SysWOW64\drivers\usbscan.sys also Evidence of drivers will be shown in Device Manager under USB at the bottom. How many Hubs do you see? That will tell you if the drivers are enabled.

  • This is all I got on that folder: usb8023.sys usbcamd.sys usbcamd2.sys usbccgp.sys usbccid.sys usbd.sys usbehci.sys usbhub.sys usbintel.sys usbport.sys usbstor.sys – supertonsky May 22 '12 at 4:52
  • There are two USB hubs and two USB Root Hubs currently showing up but the USB Flash Drive is showing as a question mark icon as any device without drivers would. – supertonsky May 22 '12 at 4:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.