I've been using MAMP for years. Rarely had any issues. I'm currently running OSX 10.7.4. I just upgraded MAMP to v2.0.5 and bought/installed MAMP PRO... but I can't get it to work. I can still you MAMP (non-PRO), but I get a 500 error when I try the same local sites with MAMP PRO.

Here's what I've tried so far...

  1. I've tried with both the MAMP port settings (Apache=8888 MySQL=8889 SSL=88890), and the default web settings (Apache=80 MySQL=3306 SSL=443). Neither works.

  2. I've tried each of the following:




  3. I've tried both user options (www/mysql & MyUser/MyUser).

In each case I get a 500 internal server error: HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

The documentation is very brief, so I'm not sure whether this looks correct for settings under the hosts tab: enter image description here Another clue, I CAN access files in the root directry: /htdocs. I just placed a file with phpinfo() and it worked! I think this tells me something, but I'm not sure what.

UPDATE For reasons that are ENTIRELY mysterious to me, I'm now getting a 403 Forbidden error, and only for one particular site in my /htdocs folder. I tried editing the httpd.conf with:

<Directory />
Options Indexes FollowSymLinks
AllowOverride All

Still no luck accessing the one site.


Still getting 500 errors or just 403?

403 are user permission errors, have you changed any of the user permissions configuration?

500 are usually the format of the page you are trying to access is not configured or not recognised

Do you still have a copy of the previous httpd.conf? I would try restoring that file and see if that works.

| improve this answer | |

After a full day of pulling my hair out, I solved this problem and learned a painful lesson...

Apparently MAMP Pro changes the PHP memory limits. So everything was configured correctly, but the site was hitting memory limits, and the errors reporting wasn't turned on, so THAT is why I was seeing the 500 error. It was a coincidence that the most recent site I installed happened to be more memory-intensive than the others. Ugh!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.