Have three computers both with windows 7 connected to each other with a TRENDnet gigabit switch, have a folder on computer A that is set as shared folder under the advanced sharing settings for the folder. When I copy from computer A to Computer B the process barely takes a second. When I copy from computer A to Computer C its the same story almost no time to copy.

The problem is when I copy from computer B to Computer A. It takes more than 5 minutes to copy the same file. This problem doesn't occur when copying from computer C to computer A, it is only when copying from Computer B to Computer A

The speed when doing this is around 13.2 KB/second even though all computers have gigabit cards and its a gigagbit switch.

I have tested with both computers B and C doing a transfer to computer A and computer B is going at 13.2 KB/second while computer C is going at ~50 MB/second

Computer A has kaspersky anti-virus installed but I disabled it, and all computers have microsoft security essentials installed. EDIT: tested another thing, I made a shared folder on computer B then went on computer A and copied from the shared folder on computer B to computer A and it worked perfectly fine at around ~70 MB/second.

so in the end the only problem is copying TO computer A's shared folder FROM computer B which seems strange to me and I'm guessing has something to do with the settings of the shared folder and not the network.

  • On your computer-B, try changing the network-adapter's duplex mode from Auto to 10-Full mode. I've seen many bandwidth issues resolving after this little fix. Also, on both A & B, monitor the usage of all applications that might be clogging your network on open ports. You can do this by running resmon.exe (Resource-monitor) on windows-7. – Prahlad Yeri Aug 7 '12 at 0:04
  • I have a similar issue. It's literally faster to send the file across the world (e.g. Dropbox upload), and re-download it on the other computer on the same desk, then transfer it via shared network folder... – Killroy Nov 5 '20 at 20:50

While I would consider the existing answers here also valid as potential solutions and it's certainly worth checking your network adapter configuration, I suspect the following two points may also be of help.

  1. For whatever reason if you are trying to copy files using UNC network paths beginning with a double back-slash such as \\machine_name\shared_folder this will often take a lot more time than if you map a drive letter to a network path. Try mapping a drive letter and see if that makes all the difference.

    In Windows the Map Network Drive button can normally be found on the toolbar when you browse to My Computer or Computer (depends on your version of Windows), or you can use the command prompt if you prefer:

    net use n: \\machine_name\shared_folder /persistent

  2. One other thing to bear in mind, is that if your folder has a lot of small individual files alot of processing time and bandwidth can be taken up with the file headers, and so if this is the case it is usually much quicker to compress the folder using your favourite tool (mine is 7zip) and then copy or move the compressed file over the network as a single file instead of hundreds of individual smaller files, and then simply uncompress the file again at the other end to extract your files.

    The impact of this is very noticeable when using protocols such as FTP, S-FTP or SCP for file transfers if you ever find yourself copying files to and from remote web servers.


Just a guess but Antivirus? In particular, does either Computer A or Computer B have two conflicting antivirus products installed?

  • computer A has kaspersky installed but I disabled it when I started testing to try to see what was wrong, also they both have Microsoft Security Essentials. – Luis F Hernandez May 23 '12 at 15:13

Change the machine(s) tuning settings, there are known bugs with how W7 negotiates that can cause transfer slowness.

netsh interface tcp set global autotuning=disabled (or highly restricted)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.