Today I replace my FastEthernet switch with a newly bought gigabit switch (DGS-1008A). All computers in my house are displaying that the connection speed is 1 Gbps except for one.

The computer that is not working is an ASUS M2N-MX which contain an onboard gigabit NIC. See ASUS link for confirmation http://www.asus.com/Motherboards/AMD_AM2/M2NMX/

Here are some info of the machine

  • OS: Windows 7 Ultimate SP1 64bit
  • BIOS version: 1004 (latest)
  • Driver: installed via Windows update (latest from Windows update)
  • Windows Update: fully updated
  • The machine is reformatted 3 days ago, so it's pretty clean, no junk, no virus, etc Cable: Amp CAT5E 5 meters

In device manager, the name of the NIC is "NVIDIA nForce 10/100/1000 Mbps Ethernet"

What I have try:

  1. I did try to install the driver provided in ASUS website, but there isn't any for Windows 7 64 or Vista 64.
  2. I did try to install the latest nForce340/6100, downloaded from Nvidia website. However, the LAN driver refuse to install, it complain that I already have the best driver installed.
  3. I looking in the property --> advance tab --> Speed/duplex settings, in an attempt to force it to run at 1000Mbps, but there is no 1000Mbps choice, only 10 and 100Mpbs.
  4. I change the CAT5E cable (use one from another computer that is running gigabit without problem)

Anyone have this issue or know how to solve it?

  • This comment is a bit late, but have you ever tried boot Linux from a Live-CD and checked the bitrate there? Just to see if the hardware is ok.
    – ott--
    Aug 6, 2013 at 12:07

2 Answers 2


I have that problem too, been busy a whole long night finding a driver for server 2003 x64 for this motherboard nic.

I don't know anymore which driver I took but suddenly it worked, but with exception the 1gbit speed isn't selectable.

Checked out some of the driver files in the system and saw some strange things in them, one file did mention that 1000mbps was selectable with a parameter #9 for 1000mbps , while a other part file of the driver shows only selections till 100mbps ...

I really think there are bugs in this drivers, i did try to find out things in the windows registry but couldn't localize the right lines, prob if you can find it you maybe can modify some registry lines to make 1000mbps selectable in the network menu.

I give up till now, will try to find a pci network card like an intel one for the best driver support.


If you only see 10/100 under duplex, it is possible that the driver is incorrect or the device is damaged... or, there is something else to blame... (Wrong motherboard/wrong chip on board etc.)

The duplex and settings screen is not linked to the current infrastructure - you should be able to select 1000Mb even on a 100meg network... It wouldn't work, but you should still be able to select it.

update -- just double checked to confirm.

You state that you tried the latest nForce 340... Your motherboard is nForce430 - try the download from this link - http://www.nvidia.co.uk/object/nforce_vista_win7_32bit_15.49_uk.html

  • Is there a way to force the windows to use other driver? Because I try to use other driver and it's won't accept it. It keeps saying that you already have the best driver installed.
    – chmod
    May 23, 2012 at 18:18
  • Uninstall the last one by right clicking and choose to delete as well - but take a backup first. May 23, 2012 at 18:22
  • Thanks, done that, still only 10 and 100, using the nForce driver for vista64. I can't find any Win7 64 driver.... :(
    – chmod
    May 23, 2012 at 18:31
  • This is in no way an indication of a faulty driver. Instead, not being able to select 1000 Mbit/s is the rule. Very few drivers actually allow this. That is because 1000 Mbit/s requires auto-negotiation.
    – Daniel B
    Feb 20, 2014 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.