I have a Western Digital 1023 Elements 1TB External USB HDD. Recently, it has started an unusual problem. I cannot copy any file of any size on to that 1TB hard-drive, eventhough it has more than 400 GB free (out of 931GB actual size). I tried copying movies from one friends laptop, which did not work. I also tried another desktop to copy some study material e-books (in PDF), which also did not work. I get same CRC error when I try to copy anything from a computer's hard-drive onto this WD 1TB hard-drive.

Vice-versa it's working. I mean, I can copy any file from the USB HDD onto local machine's HDD on any computer. It's like one-way traffic. This HDD is only 1 year old.

What are my options? Any suggestions?

  • Have you attempted to scan the disk for errors and possibly bad sectors? What operating system are you attempting to copy from? – PeanutsMonkey May 23 '12 at 19:07
  • Another option would be to remove the external harddrive and place in a PC so see whether you can copy back and forth. If the drive is S.M.A.R.T enabled, you could run the relevant tools against it to see whether it has any major issues. – PeanutsMonkey May 23 '12 at 19:11
  • A good tool to use would be crystalmark.info/software/CrystalDiskInfo/index-e.html. You won't even have to remove the external harddrive. – PeanutsMonkey May 23 '12 at 19:14
  • While I agree that the most likely source of the problem is a hardware failure, given the dearth of info I would like to cover my bases first: how many partitions do you have on the disk? Are there disk quotas? As for its age, it is unfortunately irrelevant: a disk life-cycle is determined by the number of write operations, not by its age. – MariusMatutiae Oct 22 '13 at 6:45

It sounds like a fault on the controller on the hard disk (or USB case). You should see if you can copy the data off it and then RMA the drive [ drives fail all the time, a decent supplier should not give you too much hassles if its in warranty ].

One other thing to do is to check the "SMART" data on the drive, which may simply tell you if the drive thinks its faulty. [ If SMART says it is, it is, if it says it isn't it still might be ]. I am a Linux person, so don't know too much about SMART for Windows, but I found a link to HDTUNE which looks like it would allow you to read the SMART data for free as a one off. [ I am sure there are other programs which can do it as well ]


It's dead. You can still read from it, but you can't write to it. Copy your data off as quickly as possible because the disk is dead / dying.

  • 2
    It's an assumption that the harddrive is dying especially if he hasn't run any diagnostics against it. – PeanutsMonkey May 23 '12 at 19:08
  • I agree, all answers are assumptions when the question is vague. The problem moves with the disk, not the computer, it matches behaviour I've had before, and it doesn't appear to be related to any changes (as far as we can determine). Also, it's generating CRC errors. Maybe the cable is faulty, maybe the USB port is faulty, maybe a hundred other things as well, given past experience, it's more likely the 1TB drive is failing, but without more diagnostics, that's all I have. – EightBitTony May 23 '12 at 19:10
  • @PeanutsMonkey ... I've tried this same HDD on 3 different systems. 2 with Win7 & 1 with XP-SP3. Cable does not look bad. I've tried using different USB slots on different computers. Situation is still the same. Makes no difference. I still keep getting CRC errors when trying to copy anything from the PC/Laptop onto this USB HDD. I'll try CHKDSK /F/R on it. If it does not help, I'll have to copy everything onto some other drive & send this for warranty replacement, since warranty I believe is for 3 years. Thanks guys. – Aashish Vaghela May 23 '12 at 19:29
  • @Aashish Vaghela - Give crystalmark.info/software/CrystalDiskInfo/index-e.html a go as it'll yield interesting results in terms of what is wrong with your harddrive. – PeanutsMonkey May 24 '12 at 2:20

What is the format? NTFS - FAT32 - EXT3... Are the files copied to the root or do you have a subdirectory tree in place? Some formats have limits on the total number of files you can have in the root regardless of space. Take a look at this https://stackoverflow.com/questions/466521/how-many-files-in-a-directory-is-too-many

protected by slhck Nov 12 '12 at 18:54

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.