19

Is there a way to disable/lock the mouse/touchpad zoom in the Chrome browser? I find myself accidentally triggering ctrl-wheel or touchpad-two-finger far more often than do intentionally.

As an afterwards bandaid fix, Ctrl-0 will quickly restore zoom to 100%.

2
10

For a quick and dirty solution I found @ http://productforums.google.com/forum/#!category-topic/chrome/discuss-chrome/-rtDLZmN9bk

Followed rd2020's comment for AutoHotkey (as I am already running it for other things)

Downloaded AutoHotKey software In the AutoHotkey.ahk file, added these to do nothing for Cntrl+MouseWheelScrolling

#IfWinActive ahk_class Chrome_WidgetWin_1
{
    ^WheelDown::return 
    ^WheelUp::return
    #MaxHotkeysPerInterval 1000
}
2
  • This solution still works in 2017.
    – Nelson
    Apr 19 '17 at 15:47
  • Note, use administrator authority to run this AHK ,or it would not take effect .
    – Mithril
    Feb 4 '21 at 8:33
1

There is an extension that can prevent it.

Just make sure to

NoMouseWheelZoom

Installation Instructions
1. Install the extension
2. Go to extension settings. Make sure that "allow access to file url's" is checked
3. Refresh Your tabs

1
  • 3
    NoMouseWheelZoom currently (end 2016) does not work. Dec 27 '16 at 22:02
0

Does

<meta content='True' name='HandheldFriendly' />
<meta content='width=device-width; initial-scale=1.0; maximum-scale=1.0; user-scalable=0;' name='viewport' />

not work for you?

4
  • 2
    how/where would you put that? As a userscript or through something else?
    – Journeyman Geek
    Jun 11 '12 at 5:51
  • That does work, but it's for the wrong problem ;) After a way to lock browser zoom on all sites Jun 11 '12 at 9:41
  • Any way to make this work on any browser (desktop or mobile)?
    – Danny
    Oct 23 '13 at 12:13
  • The content of viewport should be comma delimited. Jan 30 '18 at 15:25
-1

However this is not possible yet on chrome but you can use an extension called zoom lock.

For windows there is a solution on Google product forum open the - controlpanel hardware settings mouse device settings, and then search for the setting were you can disabe the pinch zoom.

Also see this discussion.

2
  • 1
    Thanks for googling it, but Zoom Lock does NOT lock the zoom to a set level, it allows you to predetermine zoom levels for your favourite sites. Nor does disabling the shortcut with Shortcut Manager. Disabling pinchzoom for the whole system is a "workaround", not a solution, and eliminates a core functionality that is very useful in many other scenarios. May 25 '12 at 22:20
  • 1
    @WulfSolter Here is an alternative extension "Zoom Block", which actually does prevent zoom modifications (until re-enabled for a specific tab): chrome.google.com/webstore/detail/zoom-block/…
    – Venryx
    Mar 7 '20 at 1:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.