Possible Duplicate:
How do I delete a file that is in use by another process?

When I tried to delete a file or folder on my Windows 7 computer I received the following messages:

  • Can not delete file: Access is denied

  • Can not delete folder: It is being used by another person or program

Is there an easy way to delete a file that can not be deleted because of these two messages?

  • 2
    First of all, is it in use? Are you running any programs that could have a lock on the folder or its contents? – iglvzx May 25 '12 at 23:19
  • i think, i'm not running anything Applications or program – Perdana Putra May 25 '12 at 23:22

Try delete with IObit Unlocker software; its simple Solution for "cannot delete" problems on Windows.


  • it's free ? thank's for your advice .. – Perdana Putra May 25 '12 at 23:20
  • yeah, its easy to use & free .. – Reniata Cristiani May 25 '12 at 23:29

Like IObit Unlocker in @Reniata Cristiani answer, Fix ‘Cannot Delete Folder/File’, ‘Access Is Denied’ or ‘File In Use’ errors in Windows Using "LockHunter"

is a free tool for Windows that is quite similar to Unlocker but with a twist. It integrates itself to the Windows Explorer right-click context menu, just right-click the locked file and select ‘what is locking this file?’ and it will show you the process that is locking the file



There is one more possibility which I ran into.

In my case, I could not even take Ownership of the folder. When applying the change, an 'Access is denied.' error was presented.

The problem for me was that I had included this folder I was trying to delete in my Pictures Library Locations.

Brief explanation:

If you browse to any Library, you'll notice at the top of the Explorer window it says "Includes: 3 locations" (or some number). Click that and it shows you the list of folders it aggregates to form the Library itself.

The folder I was trying to delete was here, and once it was removed, the folder can be deleted (or it may delete itself automatically if it was set to be deleted as part of an application Uninstall previously)

Hope this helps someone :) Certainly it's a bug.


You will probably want to try some of the software that has been mentioned first, but you can delete the files or folders in BIOS before the OS even starts. I had this problem once with some large video files, and this was the only method that worked. You might want to try this if nothing else solves your problem.

Not the answer you're looking for? Browse other questions tagged or ask your own question.