Fairly regularly (certainly more regularly than not) I run into an issue when editing more than one file in vim (on OSX) - I'll open a set of files with

vim *.txt

Edit a file, save it, close the buffer, edit the next file and save and so on - but fairly regularly I'm kicked out of vim and back into the shell with the message "Caught deadly signal SEGV" leaving me with a shell that looks like this:

vim *.txt
20 files to edit
Vim: Caught deadly signal SEGV
Vim: preserving files...

Vim: Finished.
Segmentation fault: 11

This error only appears when I'm editing multiple files.

I've had a bit of a google - tried the instructions at http://mrraph.net/WordPress/?p=5, and found the similar question Problem with VIM - but that appears to be a different scenario and the answers were a choice of reinstall and file a bug report. I'm looking for a fix/and or an explanation of what's going on...


Cobrakai$vim --version VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Jun 24 2011 20:00:09) Compiled by [email protected] Normal version without GUI. Features included (+) or not (-): -arabic +autocmd -balloon_eval -browse +builtin_terms +byte_offset +cindent -clientserver -clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments -conceal +cryptv +cscope +cursorbind +cursorshape +dialog_con +diff +digraphs -dnd -ebcdic -emacs_tags +eval +ex_extra +extra_search -farsi +file_in_path +find_in_path +float +folding -footer +fork() -gettext -hangul_input +iconv +insert_expand +jumplist -keymap -langmap +libcall +linebreak +lispindent +listcmds +localmap -lua +menu +mksession +modify_fname +mouse -mouseshape -mouse_dec -mouse_gpm -mouse_jsbterm -mouse_netterm -mouse_sysmouse +mouse_xterm +multi_byte +multi_lang -mzscheme +netbeans_intg -osfiletype +path_extra -perl +persistent_undo +postscript +printer -profile -python -python3 +quickfix +reltime -rightleft -ruby +scrollbind +signs +smartindent -sniff +startuptime +statusline -sun_workshop +syntax +tag_binary +tag_old_static -tag_any_white -tcl +terminfo +termresponse +textobjects +title -toolbar +user_commands +vertsplit +virtualedit +visual +visualextra +viminfo +vreplace +wildignore +wildmenu +windows +writebackup -X11 -xfontset -xim -xsmp -xterm_clipboard -xterm_save system vimrc file: "$VIM/vimrc" user vimrc file: "$HOME/.vimrc" user exrc file: "$HOME/.exrc" fall-back for $VIM: "/usr/share/vim" Compilation: gcc -c -I. -D_FORTIFY_SOURCE=0 -Iproto -DHAVE_CONFIG_H -arch i386 -arch x86_64 -g -Os -pipe Linking: gcc -arch i386 -arch x86_64 -o vim -lncurses

  • Catching SIGSEG means a bug in the application, so even if some workaround would be found (like deleting custom vim config file like the pages you've linked advise), it would be better to file a bugreport anyway for the issue to be fixed.
    – aland
    May 26, 2012 at 19:59
  • What version of Vim, including patchlevel? (vim --version)
    – Heptite
    May 26, 2012 at 21:03
  • added info on version
    – Joe
    May 26, 2012 at 22:39
  • vim --version would give more useful information. (double dashes), vim didn't understand your single-dash command, and just output a header. Mine returns: VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Feb 11 2012 03:54:05) Included patches: 1-429 Modified by [email protected] Compiled by [email protected] ... and then a whole bunch of option flags
    – lornix
    May 27, 2012 at 8:06
  • Blush well I've leaned something today...
    – Joe
    May 27, 2012 at 8:48

1 Answer 1


It appears you're using a totally unpatched version of 7.3, but there have literally been hundreds of patches for 7.3 and a number address crashing issues. Without knowing more about your configuration, there is no way I can tell you if your particular crashing issue has been addressed, but the wisest thing to do is to see if you can obtain a more recent Vim with patches applied.

This link may help you: http://www.vim.org/download.php#mac

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .