I have a scheduled defrag task on my Windows XP machine to wake up the computer and run at 3:00am every day. Then I have two other scheduled tasks, one to reboot the machine after the Defrag at 3:45am, and the other to put it into sleep mode at 5:30am. This would mean that it would be in sleep mode and ready for me to wake it and log in at around 9:00am.

On many days, the scheduled task works as expected. However, there are some days when I log into the computer in the morning, and the defrag task immediately starts, which is not at the appointed time of 3:00am.

I’m not sure why it did not run at its appointed time at 3:00am, but even if that was the case, I don’t want it to kick off as soon as I log in. How can I configure the scheduler to not start a task, which was not successfully run at the appointed time, when I log in?

1 Answer 1


First thing. Check if the task is actually waking up the computer from sleep.(Just reschedule it to 9 AM and hibernate/sleep and see if PC wakes up for task.)

If not,

you need to check BIOS configuration to check the wake up settings(They differ for different MoBo)

also disable the "prompt password on wake up" setting.

And check this question.

If all else fails, get this third party program.

  • Well the scheduled tasks status indicates to me that it is waking up the computer from sleep based on its last run time. But I did your test anyway and confirm that it is indeed waking up. I also think the 'prompt password on wake up' setting is available in Windows 7 and not XP. May 29, 2012 at 7:11
  • Actually, after some googling, it seems that the 'prompt password' option is available in XP under the Advanced tab of the Power Options settings in control panel. However, mine is showing that it is checked, but disabled and greyed out? May 29, 2012 at 7:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .