I have a problem using WiFi on my Dell M4600 running Windows 7 x64. I'm using a Virgin Media Netgear Super Hub in the UK to connect to the internet. It works fine when I use a wired connection, but if I try to use WiFi I can't browse to any website.

I've tried to narrow things down to find out exactly where the fault lies, but I'm not getting very far. This is what I have tried, and know so far:

  • Wired connection works, WiFi doesn't.
  • Other devices work, my Mac Book Pro and iPhone can both use the same WiFi connection to browse websites.
  • While connected on WiFi, PING and DNS works (which means the Win7 network troubleshooter can't find any problems).
  • Using Wireshark, I can see that the http [SYN] packets do not get a response like they normally would when I compare with a trace on a wired connection.
  • I've checked the router config, and made sure that there are no rules that block or limit anything.
  • I switched off UPnP to see if that was causing a problem, it made no difference.
  • I've tried both IE and Firefox, and checked their network settings to ensure that it wasn't set to use a proxy or something. Both browsers experience the same problem.
  • I've tried temporarily disabling anti virus protection, but no difference.

I'm not sure what else to try. As other devices work with no problems, it would point to a problem with my laptop, but the wireshark trace shows that it's not getting a response to the http [SYN] which points to a router problem or something beyond the router. A wireshark trace showing an attempt at browsing to Google while on WiFi is shown below.

Does anybody have any idea what could be the problem, or what else to try?

Wireshark trace

  • try setting 802.11n to disabled – Coolnesski Jul 21 '17 at 21:45

For me similar problem was resolved in command line with commands:

ipconfig /flushdns
ipconfig /release
ipconfig /renew

In Vista/Win7 you need to run it as Administrator

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.